RubyGems and bin/


#1

I’ll readily admit that I haven’t looked into this much yet. I
thought I would ask here first and get the 10,000 foot view and
pointers for where to dig further.

I’m interested in RubyGems multiple versions feature. I need to be
able to select the version that runs at any given time. The
complication is that the gem installs a bin/ script that is the
primary interface. Can someone explain how RubyGems handles that?

Thanks.

James Edward G. II


#2

On 12/16/05, James Edward G. II removed_email_address@domain.invalid wrote:

I’m interested in RubyGems multiple versions feature. I need to be
able to select the version that runs at any given time. The
complication is that the gem installs a bin/ script that is the
primary interface. Can someone explain how RubyGems handles that?

I think it is just

myapp 1.2.3 --options-to-my-app args_for_my_app

where 1.2.3 is the version you want to run.
Otherwise, it runs the latest version.

Is that what you are asking?


#3

On Dec 16, 2005, at 9:03 AM, Jim F. wrote:

where 1.2.3 is the version you want to run.
Otherwise, it runs the latest version.

Is that what you are asking?

Sure is. Wow, that was easy. Thanks much!

James Edward G. II