Rubygems 1.8.14 breaks yaml?

The following started happening after updating rubygems to 1.8.14 today.
This is on ruby 1.9.3p0 (2011-10-30) [x86_64-linux]. Does anyone else
see this? Thought I’d ask here as a sanity check before filing a bug…

require ‘yaml’
require ‘nokogiri’ # any gem here

END
/usr/local/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:50:in
initialize': uninitialized constant Gem::Requirement (NameError) from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:1208:innew’
from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:1208:in gem' from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:651:inload_yaml’
from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/requirement.rb:18:in
<top (required)>' from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire’
from
/usr/local/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:8:in<top (required)>’
from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:203:in
try_activate' from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:58:inrescue in require’
from
/usr/local/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in
require' from gem-bug.rb:2:in

Confirmed - I had the exact same problem. Reverting back to 1.8.12
fixed the problem.

On 01/06/2012 11:08 AM, Devon G. wrote:

Confirmed - I had the exact same problem. Reverting back to 1.8.12
fixed the problem.

Thanks for checking. Filing bug now…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs