RubyGems 1.3.6, Bundler, etc

While trying to install DataMapper from source, I ran into a few
additional
issues. I can create cases if they are legit, but I suspect I’m just
missing
something. When I tried to install dm-more, I received an error stating
I
didn’t have bundler installed. When I tried installing bundler, I
couldn’t
because it requires RubyGems 1.3.6. When I tried executing ir -S gem update --system, I received the following:

C:\Users\ryan>ir -S gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.6
Updating RubyGems to 1.3.6
Installing RubyGems 1.3.6
ERROR: While executing gem … (Gem::Exception)
[BUG] invalid exec_format “ir”, no %s

Is IronRuby telling me it has a known bug, or is this something else?
Can I
upgrade to RubyGems 1.3.6? Can I install Bundler?

Thanks,

Ryan R.

Email: [email protected]
LinkedIn: http://www.linkedin.com/in/ryanriley
Blog: http://wizardsofsmart.net/
Twitter: @panesofglass
Website: http://panesofglass.org/

This is a bug in RubyGems. It seems that we can get around it by
providing lib/rubygems/ironruby.rb file:

http://rubyforge.org/tracker/index.php?func=detail&aid=27995&group_id=126&atid=575

Tomas

From: [email protected]
[mailto:[email protected]] On Behalf Of Ryan R.
Sent: Thursday, April 22, 2010 10:07 PM
To: [email protected]
Subject: [Ironruby-core] RubyGems 1.3.6, Bundler, etc.

While trying to install DataMapper from source, I ran into a few
additional issues. I can create cases if they are legit, but I suspect
I’m just missing something. When I tried to install dm-more, I received
an error stating I didn’t have bundler installed. When I tried
installing bundler, I couldn’t because it requires RubyGems 1.3.6. When
I tried executing ir -S gem update --system, I received the following:

C:\Users\ryan>ir -S gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.6
Updating RubyGems to 1.3.6
Installing RubyGems 1.3.6
ERROR: While executing gem … (Gem::Exception)
[BUG] invalid exec_format “ir”, no %s

Is IronRuby telling me it has a known bug, or is this something else?
Can I upgrade to RubyGems 1.3.6? Can I install Bundler?

Thanks,

Ryan R.

Email: [email protected]mailto:[email protected]
LinkedIn: http://www.linkedin.com/in/ryanriley
Blog: http://wizardsofsmart.net/
Twitter: @panesofglass
Website: http://panesofglass.org/

Where exactly does the #{RUBY_ENGINE}.rb file go? I am having a hard
time
finding the location. I changed the impl. of default_exec_format and was
able to update RubyGems. However, I think adding the ruby engine file is
a
better way to go.

Ryan R.

On Thu, Apr 22, 2010 at 11:39 PM, Tomas M. <

This is the comment we got from Eric (RubyGems maintainer).

JD

Comment By: Eric H. (drbrain)
Date: 2010-04-20 20:47

Message:
rubygems/defaults/ironruby.rb would go in RbConfig::CONFIG[‘rubylibdir’]
(not in RuybGems) so it should be picked up even by setup.rb

From: [email protected]
[mailto:[email protected]] On Behalf Of Ryan R.
Sent: Saturday, April 24, 2010 11:33 AM
To: [email protected]
Subject: Re: [Ironruby-core] RubyGems 1.3.6, Bundler, etc.

Where exactly does the #{RUBY_ENGINE}.rb file go? I am having a hard
time finding the location. I changed the impl. of default_exec_format
and was able to update RubyGems. However, I think adding the ruby engine
file is a better way to go.

Ryan R.

On Thu, Apr 22, 2010 at 11:39 PM, Tomas M.
<[email protected]mailto:[email protected]>
wrote:

This is a bug in RubyGems. It seems that we can get around it by
providing lib/rubygems/ironruby.rb file:

http://rubyforge.org/tracker/index.php?func=detail&aid=27995&group_id=126&atid=575

Tomas

From:
[email protected]mailto:[email protected]
[mailto:[email protected]mailto:[email protected]]
On Behalf Of Ryan R.
Sent: Thursday, April 22, 2010 10:07 PM

To: [email protected]mailto:[email protected]
Subject: [Ironruby-core] RubyGems 1.3.6, Bundler, etc.

While trying to install DataMapper from source, I ran into a few
additional issues. I can create cases if they are legit, but I suspect
I’m just missing something. When I tried to install dm-more, I received
an error stating I didn’t have bundler installed. When I tried
installing bundler, I couldn’t because it requires RubyGems 1.3.6. When
I tried executing ir -S gem update --system, I received the following:

C:\Users\ryan>ir -S gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.6
Updating RubyGems to 1.3.6
Installing RubyGems 1.3.6
ERROR: While executing gem … (Gem::Exception)
[BUG] invalid exec_format “ir”, no %s

Is IronRuby telling me it has a known bug, or is this something else?
Can I upgrade to RubyGems 1.3.6? Can I install Bundler?

Thanks,

Ryan R.

Email: [email protected]mailto:[email protected]
LinkedIn: http://www.linkedin.com/in/ryanriley
Blog: http://wizardsofsmart.net/
Twitter: @panesofglass
Website: http://panesofglass.org/


Ironruby-core mailing list
[email protected]mailto:[email protected]
http://rubyforge.org/mailman/listinfo/ironruby-core

Confirming, that it seems to work properly for me:

C:\IronRuby1.0_V4>ir
IronRuby 1.0.0.0 on .NET 4.0.30319.1 Copyright © Microsoft
Corporation.
All rights reserved.

require ‘rubygems’
=> true

RbConfig::CONFIG[‘rubylibdir’]
=> “C:/IronRuby1.0_V4/lib/ruby/1.8” # <-- Sounds like it should go here.

I then created an ironruby.rb
in: C:\IronRuby1.0_V4\Lib\ruby\1.8\rubygems\defaults
my ironruby.rb just commented out the “unless” block.
after that, “igem update --system” just worked., as did the install of
the
bundler gem.

Was there a version of ironruby.rb attached somewhere earlier with all
of
the appropriate overrides? - I just guessed.
Thanks
Best Regards,
Kevin R.

My own ironruby.rb: http://gist.github.com/379763
http://gist.github.com/379763Thanks - Kevin

On Mon, Apr 26, 2010 at 1:23 PM, Kevin R.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs