Rubygems 1.3.1 instala rails 2.2.2 en lugar de 2.3


#1

Hola a todos,

llevo un par de días intentando instalar rails 2.3 en mi portátil con
ubuntu 8.10.

sigo las intrucciones que indican en la página oficial de rails que se
resumen en lo siguiente.

wget http://rubyforge.org/frs/download.php/45905/rubygems-1.3.1.tgz
tar xzvf rubygems-1.3.1.tgz
cd rubygems-1.3.1
sudo ruby setup.rb
sudo ln -s /usr/bin/gem1.8 /usr/bin/gem
sudo gem update --system

pero ‘gem update --system’ mi devuelve ‘nothing to update’. Esto es
sospechoso porque en las máquinas con 8.04.1 sí que hacía algo. El caso
es que cuando instalo rails con ‘gem install rails’ me instala la
versión 2.2.2 en lugar de la 2.3

He reinstalado varias veces el rubygems y seguro que la version es
1.3.1.

Lo más parecido que he encontrado a un error me sale al hacer el debug
de ‘gem update --system’

$ sudo gem update --system --debug
Exception NameError' at /usr/local/lib/site_ruby/1.8/rubygems/command_manager.rb:134 - uninitialized constant Gem::Commands::UpdateCommand Updating RubyGems ExceptionGem::LoadError’ at
/usr/local/lib/site_ruby/1.8/rubygems.rb:636 - Could not find RubyGem
sources (> 0.0.1)

Nothing to update

Alguna idea para instalar correctamente rails 2.3


#2

gem install rails --source http://gems.rubyonrails.org ¿?

Sino prueba a buscarlo en git

El 22 de febrero de 2009 19:08, Gonzalo C. <
removed_email_address@domain.invalid> escribió:


#3

Andrés eres un crack!!!

perfecto, me pidió que instalase antes ‘rack’
tras hacer ‘gem install rack’ ya pude lanzar la operación que me decías

muchas muchas gracias!

Andrés Gutiérrez wrote:

gem install rails --source http://gems.rubyonrails.org ¿?

Sino prueba a buscarlo en git

El 22 de febrero de 2009 19:08, Gonzalo C. <
removed_email_address@domain.invalid> escribió:


#4

Me alegro de haberte ayudado.

Un saludo

El 22 de febrero de 2009 20:32, Gonzalo C. <
removed_email_address@domain.invalid> escribió: