Rubygems 0.9.4 problem on Ubuntu drake


#1

Hi all,

I’ve just installed RubyGems 0.9.4 from source (not thru apt-get
package) under Ruby 1.8.6 (also source install) and everything went
great.

But, upon first usage, say installing Rails via:

gem install rails --include-dependencies --debug

I’ll get a whole whackload of Exception ‘NameError’ from
command_manager.rb:145 - uninitialized constant
Gem::Commands::BuildCommand (and every other possible command).

The file command_manager.rb file (located at:
/usr/local/lib/ruby/site_ruby/1.8/rubygems) line 145 is doing this:

Gem::Commands.const_get("#{command_name.capitalize}Command").new

And that’s called once per command that’s defined in the commands
directory resulting in errors like these:

Exception NameError' at /usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:145 - uninitialized constant Gem::Commands::BuildCommand ExceptionNameError’ at
/usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:145 -
uninitialized constant Gem::Commands::CertCommand
Exception `NameError’ at
/usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:145 -
uninitialized constant Gem::Commands::CheckCommand

Here’s my rubygems environment from gems itself

RubyGems Environment:

  • VERSION: 0.9.4 (0.9.4)
  • INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8
  • GEM PATH:
    • /usr/local/lib/ruby/gems/1.8
  • REMOTE SOURCES:

And here’s my PATH environment variable:
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games

I’m running linux under Ubuntu 6.06.1, fresh install, with Ruby 1.8.6
compiled from source and extended with zlib library.

Anyone have any ideas of what’s going on here?

Many thanks,

Ben