Rubygem: ispunity (unite all your internet connections)

Dear friends,

It gives me pleasure to let everyone know that rubygem “ispunity” is now
available.

IspUnity is a open source software built to integrate (load balance &
failover) multiple internet connections simultaneously.

With IspUnity, you can

  • Use multiple internet connections simultaneous and get all their
    throughput.

Automatic failover on working net connection if any on the internet

connection goes down.

and more…

IspUnity can be used by individuals or SME or Enterprises.

Your valuable feedback and suggestions are welcome.

To know more:
website: http://www.ispunity.com
github: https://github.com/aruntomar/isp_unity
rubygems: https://rubygems.org/gems/ispunity
twitter: https://twitter.com/#!/ispunity
https://twitter.com/#!/ispunity

On Tue, May 1, 2012 at 11:34 AM, Arun T. [email protected]
wrote:

  • Use multiple internet connections simultaneous and get all their
    throughput.

Automatic failover on working net connection if any on the internet
connection goes down.
and more…

IspUnity can be used by individuals or SME or Enterprises.

Your valuable feedback and suggestions are welcome.

Ryan B. over at railscasts did a fantastic capistrano recipes episode
where he dev ops a ruby environment with rbenv.
You might want to consider offering some kind of deploy script which
will
install a ruby env if none exists.

Other than that, thank you for your hard work and for making this open
source.

Andrew McElroy

On 05/01/2012 10:15 PM, andrew mcelroy wrote:

IspUnity is a open source software  built to integrate (load

Other than that, thank you for your hard work and for making this open
https://twitter.com/#!/ispunity

--
Regards,
Arun T.

Thanks for the feedback Andrew. Actually we want to make at as simple as
installing rvm. We’ve already made the script and testing it. The idea
is to release what we have ready and keep adding more features to it and
any supporting things along with it.

You are using Ruby 1.8.x, and ISPunity apparently requires Ruby 1.9.x.

As far as I know Ruby 1.9 for Ubuntu is available thru the package
manager, under the name “ruby19” or something like that. After
installing it you might have to run it as “ruby19”, too; consider
installing RVM (https://rvm.io/) if you don’t like this.

– Matma R.

Hi!

Certainly we’ll help you and anyone who’s trying to use ISPunity and
facing any issue.
I’m assuming that if you’ve followed the steps, you would have installed
rvm and ruby 1.9.3 but ubuntu comes with ruby 1.8.7. what you need to do
is to make your system use ruby 1.9.3 rather than the system default i.e
1.8.7.

You can do that by the following command.

rvm use 1.9.3 --default

after that install the gem

gem install ispunity

create the config file as per your network .

then run
ispunity setup

and put the following command in your cron settings to run after every 5
mins, so that it’ll check for the dead gateways and automatically
failover.
ispunity monitor

We’ll be updating the documentation soon for the cron settings.

Feel free to mail us. We are here to resolve any problems and improve
the app based on the feedback.

Hi sir,
i am an ubuntu home pc user, running 12.04 LTS. I heard about Ispunity
from EFY times( actually i was searching for such an application. First
thanks for developing such an application and making it free & Open
source.

I tried to install Ispunity as per ur guide lines when i tried to run
it it gave error reports as below. If u have time pls help, thanks.

/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in
gem_original_require': /var/lib/gems/1.8/gems/ispunity-0.0.4/lib/system_call.rb:22: undefined (?...) sequence: /inet addr:(?<ip>(\d+[.]){3}\d+)/ (SyntaxError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:inrequire’
from /var/lib/gems/1.8/gems/ispunity-0.0.4/lib/isp_unity.rb:7
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in
gem_original_require' from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:inrequire’
from /var/lib/gems/1.8/gems/ispunity-0.0.4/bin/ispunity:4
from /usr/local/bin/ispunity:19:in `load’
from /usr/local/bin/ispunity:19

Arun T. wrote in post #1060604:

Hi!

Certainly we’ll help you and anyone who’s trying to use ISPunity and
facing any issue.
I’m assuming that if you’ve followed the steps, you would have installed
rvm and ruby 1.9.3 but ubuntu comes with ruby 1.8.7. what you need to do
is to make your system use ruby 1.9.3 rather than the system default i.e
1.8.7.

You can do that by the following command.

rvm use 1.9.3 --default

after that install the gem

gem install ispunity

create the config file as per your network .

then run
ispunity setup

and put the following command in your cron settings to run after every 5
mins, so that it’ll check for the dead gateways and automatically
failover.
ispunity monitor

We’ll be updating the documentation soon for the cron settings.

Feel free to mail us. We are here to resolve any problems and improve
the app based on the feedback.

Hi Sir, I have done it as per ur instructions, and my current ruby
version is 1.9.3 but it still gives the same output as follows. Pls help
thanks.

[email protected]:~$ sudo su
[sudo] password for nanthiyadan:
[email protected]:/home/nanthiyadan# rvm use 1.9.3
–default
Using /usr/local/rvm/gems/ruby-1.9.3-p194

[email protected]:/home/nanthiyadan# rvm current
ruby-1.9.3-p194
[email protected]:/home/nanthiyadan# ispunity
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in
gem_original_require': /var/lib/gems/1.8/gems/ispunity-0.0.4/lib/system_call.rb:22: undefined (?...) sequence: /inet addr:(?<ip>(\d+[.]){3}\d+)/ (SyntaxError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:inrequire’
from /var/lib/gems/1.8/gems/ispunity-0.0.4/lib/isp_unity.rb:7
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in
gem_original_require' from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:inrequire’
from /var/lib/gems/1.8/gems/ispunity-0.0.4/bin/ispunity:4
from /usr/local/bin/ispunity:19:in `load’
from /usr/local/bin/ispunity:19
[email protected]:/home/nanthiyadan#

On 05/14/2012 04:08 PM, Ajith N. wrote:

You can do that by the following command.
ispunity setup

ruby-1.9.3-p194
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in
require' from /var/lib/gems/1.8/gems/ispunity-0.0.4/bin/ispunity:4 from /usr/local/bin/ispunity:19:inload’
from /usr/local/bin/ispunity:19
[email protected]:/home/nanthiyadan#

Hi!

Your system is still looking for ispunity gem in 1.8 folders.

did you install ispunity after you confirmed that you are on ruby 1.9.3

[[email protected] ~]# ruby -v
ruby 1.9.3p125 (2012-02-16 revision 34643) [x86_64-linux]

[[email protected] ~]# gem list|grep ispunity
ispunity (0.0.4, 0.0.3, 0.0.2, 0.0.1)

if you get a similar output that means ispunity is installed in 1.9.3,
if not, then install ispunity

gem install ispunity

if you still find your system searching for ispunity in 1.8.7, switch to
1.8.7
rvm use system
then
gem uninstall ispunity
swtich to 1.9.3
rvm use 1.9.3
gem install ispunity
and then try to run the commands.

hope this helps. otherwise provide your gmail id, i can help you when
you are online on gtalk or add mine [email protected]

Arun T. wrote in post #1060652:

Hi!

Your system is still looking for ispunity gem in 1.8 folders.

did you install ispunity after you confirmed that you are on ruby 1.9.3

[[email protected] ~]# ruby -v
ruby 1.9.3p125 (2012-02-16 revision 34643) [x86_64-linux]

[[email protected] ~]# gem list|grep ispunity
ispunity (0.0.4, 0.0.3, 0.0.2, 0.0.1)

if you get a similar output that means ispunity is installed in 1.9.3,
if not, then install ispunity

Hi Sir,
I had done what u said and found system was using 1.8.7 and i
uninstalled it from synaptic and re installed thru rvm, and now it is
working.
Now i have another problem, I am using an MTS dongle and my mobile as
modem & ispunity is not giving any result. i am attaching a screenshot
and attaching my config file. pls help. thanks.

On 05/18/2012 01:48 PM, Ajith N. wrote:

[[email protected] ~]# gem list|grep ispunity
Now i have another problem, I am using an MTS dongle and my mobile as
modem& ispunity is not giving any result. i am attaching a screenshot
and attaching my config file. pls help. thanks.

Attachments:
http://www.ruby-forum.com/attachment/7402/ispnew.jpg

http://www.ruby-forum.com/attachment/7403/Screenshot_from_2012-05-18_13_37_50.jpg

http://www.ruby-forum.com/attachment/7404/ispunity.json

Hi Ajith,

Great to know that you are now able to install it properly.
once ispunity is installed and json file is configured.

You need to run
“ispunity setup”

this will setup the application and it should be the first command to be
run for the application to work properly. then “ispunity monitor” needs
to be run as a cron job ideally every 5 min for dead gateway detection
and failover. We’ll be releasing a new version and updating the
documentation with these details this weekend.

to check whether all the connections are working or not follow the link
http://www.ispunity.com/hw_to.html

remember to check your route

" ip route show "

if both your net connections are working then it should have 2 gateways.

Respected sir,
first of all very very thanks for taking this initiative to solve
problem of many like us who can’t afford 3g and broadband but we can
have more than one mobile at our room and we were in need to combine all
of them to improve internet speed, and with your software we again
reveice hope,
many many thanks.

but still there r some problems in settings,

as you have given

Normal scenario: (1 gateway)

Check the last line “default via < ip your gateway > dev < device name >

[[email protected] ~]# ip route show
61.17.193.0/24 dev eth0 proto kernel scope link src 61.17.193.163
192.168.3.0/24 dev eth1 proto kernel scope link src 192.168.3.1
192.168.0.0/24 dev eth2 proto kernel scope link src 192.168.0.1
192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
169.254.0.0/16 dev eth0 scope link metric 1002
169.254.0.0/16 dev eth1 scope link metric 1003
169.254.0.0/16 dev eth2 scope link metric 1004
default via 192.168.0.2 dev eth2

i am working with two ppp connections but as we are not linux geek so we
were unable to set below things working

169.254.0.0/16 dev eth0 scope link metric 1002
169.254.0.0/16 dev eth1 scope link metric 1003
169.254.0.0/16 dev eth2 scope link metric 1004

will you please give step-by-step instructions to do this if it possible
with ppp connections?

actually really this needs to do remaining things?

because all steps are working but i m not getting any result with
“iptraf” software.

please help us!

once again thanks a lot!

while running ispunity on terminal i get the following result

[email protected]:~$ ispunity

/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/lib/isp_unity_log.rb:12:in
new': '/var/log/ispunity.log' is not writable! (StandardError) from /home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/lib/isp_unity_log.rb:12:in<top (required)>’
from
/home/avinash/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from /home/avinash/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/1.9.1/rubygems/custom_require.rb:36:inrequire’
from
/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/lib/isp_unity.rb:4:in
<top (required)>' from /home/avinash/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/1.9.1/rubygems/custom_require.rb:36:inrequire’
from
/home/avinash/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from /home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/bin/ispunity:4:in<top (required)>’
from /home/avinash/.rvm/gems/ruby-1.9.3-p448/bin/ispunity:23:in load' from /home/avinash/.rvm/gems/ruby-1.9.3-p448/bin/ispunity:23:in<main

i had successfully installed ispunity on my ubuntu pc.Then i configured
json file and run ispunity monitor command,it shows

[email protected]:/home/avinash# ispunity monitor
/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/lib/isp_unity/routing_table.rb:21:in
rescue in config': [IspUnity] Configuration file is corrupted!! (IspUnity::IspUnityException) from /home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/lib/isp_unity/routing_table.rb:15:inconfig’
from
/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/lib/isp_unity.rb:65:in
monitor' from /home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/bin/ispunity:23:inmonitor’
from
/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/thor-0.18.1/lib/thor/command.rb:27:in
run' from /home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/thor-0.18.1/lib/thor/invocation.rb:120:ininvoke_command’
from
/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/thor-0.18.1/lib/thor.rb:363:in
dispatch' from /home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/thor-0.18.1/lib/thor/base.rb:439:instart’
from
/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/bin/ispunity:59:in
<top (required)>' from /home/avinash/.rvm/gems/ruby-1.9.3-p448/bin/ispunity:23:inload’
from /home/avinash/.rvm/gems/ruby-1.9.3-p448/bin/ispunity:23:in
`’

Dear Prashant,

ispunity commands have to run in a sequence

  1. ispunity setup
    this will setup all the rules, policies and routing table entries, if
    you’ve configured your json configuration file properly.

  2. then you can run
    "ispunity monitor " as a cron for dead gateway detection and automatic
    failover.

All these instructions will be updated in the new version to be released
shortly. Feel free to mail us for further queries. We are here to help
people to use ispunity and will provide whatever support necessary.
Enjoy :slight_smile:

Arun.

On Sat, Oct 12, 2013 at 9:45 AM, Avinash R. [email protected]
wrote:

while running ispunity on terminal i get the following result

[email protected]:~$ ispunity

/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/lib/isp_unity_log.rb:12:in

`new’: ‘/var/log/ispunity.log’ is not writable! (StandardError)
from

From this location, /var/log/ispunity.log I believe you need to run this
command as a sudo or root user. try rvmsudo ispuniy

https://twitter.com/coder_hsps | http://tech.hsps.in

On Oct 12, 2013, at 1:06 AM, Avinash R. [email protected] wrote:

i had successfully installed ispunity on my ubuntu pc.Then i configured
json file and run ispunity monitor command,it shows

[email protected]0:/home/avinash# ispunity monitor

/home/avinash/.rvm/gems/ruby-1.9.3-p448/gems/ispunity-0.0.5/lib/isp_unity/routing_table.rb:21:in

`rescue in config’: [IspUnity] Configuration file is corrupted!!

So, what’s your configuration file looking like?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs