RubyForge gem source index busted

I assume someone’s looking into this, but since I hadn’t seen a post on
it: something seems to be wrong with the gem source index on RubyForge
(or on one of the mirrors?) Trying to install gems with either JRuby or
Ruby downloads but then chews on the file forever, never completing.

Sounds very much like the index has been corrupted somehow, again.

  • Charlie

Charles Oliver N. wrote:

I assume someone’s looking into this, but since I hadn’t seen a post on
it: something seems to be wrong with the gem source index on RubyForge
(or on one of the mirrors?) Trying to install gems with either JRuby or
Ruby downloads but then chews on the file forever, never completing.

Sounds very much like the index has been corrupted somehow, again.

FYI, more info…it was fine last night as far as I could tell, but I
wasn’t doing a clean source index update. This morning I wiped out my
gems dir and it hasn’t worked since. I also tested a totally clean Ruby
install with rubygems 0.9.1 and it can’t “Bulk update” the source index
properly.

  • Charlie

Charles Oliver N. wrote:

wasn’t doing a clean source index update. This morning I wiped out my
gems dir and it hasn’t worked since. I also tested a totally clean Ruby
install with rubygems 0.9.1 and it can’t “Bulk update” the source index
properly.

Now it just completed…perhaps a bad mirror somewhere? Does the source
index get mirrored?

  • Charlie

Charles Oliver N. wrote:

FYI, more info…it was fine last night as far as I could tell, but I
wasn’t doing a clean source index update. This morning I wiped out my
gems dir and it hasn’t worked since. I also tested a totally clean
Ruby install with rubygems 0.9.1 and it can’t “Bulk update” the source
index properly.

Now it just completed…perhaps a bad mirror somewhere? Does the source
index get mirrored?

Nevermind for the moment…I think I had a rogue source cache causing
problems for both JRuby and Ruby…

  • Charlie

On Wed, 2007-02-07 at 15:50 +0900, Charles Oliver N. wrote:

Now it just completed…perhaps a bad mirror somewhere? Does the source
index get mirrored?

Nope, not yet.

Yours,

Tom

On Wed, 2007-02-07 at 17:35 +0900, Charles Oliver N. wrote:

Now it just completed…perhaps a bad mirror somewhere? Does the source
index get mirrored?

Nevermind for the moment…I think I had a rogue source cache causing
problems for both JRuby and Ruby…

Cool. Thanks for posting anyhow; better to get a false positive than to
delay action if the gem index really is corrupted…

Yours,

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs