RubyCocoa problem on Mac OS X

Hello,
I downloaded the binary version of RubyCocoa
(RubyCocoa-0.4.2-tiger.dmg) and installed it with its default options.

But seems there is a problem, because I can’t load it!

irb(main):001:0> require ‘osx/cocoa’
LoadError: no such file to load – osx/cocoa
from (irb):1:in `require’
from (irb):1

I checked the package content and checked my system too, everything is
in place, but I can’t load the library.

ruby 1.8.4 (2005-12-24) [i686-darwin8.5.2]
Mac OS X Version 10.4.7

Thank you all in advance,

  • Dunnil

Human D. [email protected] wrote:

I downloaded the binary version of RubyCocoa
(RubyCocoa-0.4.2-tiger.dmg) and installed it with its default options.

if i remeber well i had months ago something like that…

i solved it using DarwinPorts installing Ruby, RubyCocoa and RubyGems
correctly.

before that i was unable to build a rubycocoa app making use of some gem
package…

On Jul 14, 2006, at 12:47 PM, Human D. wrote:

I checked the package content and checked my system too, everything is
in place, but I can’t load the library.

ruby 1.8.4 (2005-12-24) [i686-darwin8.5.2]
Mac OS X Version 10.4.7

Thank you all in advance,

  • Dunnil

The RubyCocoa packages for whatever reason use the Apple supplied
ruby. You seem to have installed a compiled from sourc ruby (or
installed it perhaps from fink or darwinports).

try it with

/usr/bin/irb or /usr/bin/ruby

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs