Rubychess now available on Rubyforge

Rubychess is now available at rubyforge:
http://rubyforge.org/projects/rubychess/
Enjoy, and thanks in advance if you choose to help on this project.
– Glenn

Greetings

On Windows XP I’m a happy user of the Fox toolkit through Lyle J.s
excellent fxruby library.

Now I’m trying to port some applications to linux(ubuntu 6.06, ruby
1.8.4 installed from ubuntu package), but face trouble with the fxruby
gem.

I compiled and installed the latest stable fox-toolkit (1.6.16) from
source. All fine.

I install the latest gem:

 sudo gem install fxruby

All fine.

I try to run hello.rb, but it fails on require ‘fox1.6’

irb(main):001:0> require 'fox1.6'
LoadError: no such file to load -- fox1.6
        from (irb):1:in `require'
        from (irb):1

Instead, I am able to use require_gem

irb(main):002:0> require 'rubygems'
=> true

irb(main):003:0> require_gem 'fxruby'
=> true

Unfortunately I’m not able to include the Fox module

irb(main):004:0> include Fox
NameError: uninitialized constant Fox
        from (irb):4

Questions:
i) On WinXP I use: require ‘fox1.6’, shall I really use
require_gem ‘fxruby’ on linux(ubuntu)

ii) How can the include Fox problem be mended?

All the best

Jon Egil S. wrote:

I try to run hello.rb, but it fails on require ‘fox1.6’

Maybe that was a typo, but it should be

require ‘fox16’

Does it still fail?

Does it really work on windows with

require ‘fox1.6’

?

On 10/17/06, Jon Egil S. [email protected] wrote:

I install the latest gem:

     sudo gem install fxruby

All fine.

I try to run hello.rb, but it fails on require ‘fox1.6’

As Joel noted in his reply, this should be ‘fox16’ and not ‘fox1.6’.
But you’re also going to have trouble installing FXRuby from a source
gem using the current release of RubyGems, due to a bug in the
RubyGems installer; see:

http://rubyforge.org/tracker/index.php?func=detail&aid=4948&group_id=126&atid=575

For that reason, I’d recommend installing FXRuby using the regular
source tarball.

Maybe that was a typo, but it should be

require ‘fox16’

Thanks for your reply, but alas, it’s my silly typo in the email.

Does it still fail?

yes, require ‘fox16’ fails

Does it really work on windows with

require ‘fox1.6’

no, but require ‘fox16’ works.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs