Ruby1.9

Lo sto provando ma ho una serie di problemi.
Tanto per cominciare rake cucumber mi dice: undefined method task.
Torno alla 1.8 :frowning:

deve esserci un problema di altra natura, cucumber non da alcun problema
con la 1.9

hai controllato di avere tutte le gemme necessarie anche su 1.9 ?

A.

Il 20/05/2011 21:50, Mauro ha scritto:

Ciao,
mi e’ capitato un problema simile con rake 0.9.0…non ho indagato a
fondo
ma potrebbe essere un bug di questa versione di rake (se cerchi con
Google
trovi un po’ di riferimenti). Per quanto riguarda Ruby 1.9 nessun
problema
quindi ti consiglio di non tornare a 1.8.7

On Fri, May 20, 2011 at 9:50 PM, Mauro [email protected] wrote:

Lo sto provando ma ho una serie di problemi.
Tanto per cominciare rake cucumber mi dice: undefined method task.
Torno alla 1.8 :frowning:

non la 1.9, ma rake 0.9. Probabilmente lo hai installato e novo
quando hai migrato e ti sei beccato la versione nuova, che ha spostato
il DSL in un modulo diverso. Esempio di fix:

https://gist.github.com/4b4e24877b107b00bcba


twitter: @riffraff
blog en: http://www.riffraff.info
blog it: http://riffraff.blogsome.com
work: http://cascaad.com

2011/5/22 gabriele renzi [email protected]:

On Fri, May 20, 2011 at 9:50 PM, Mauro [email protected] wrote:

Lo sto provando ma ho una serie di problemi.
Tanto per cominciare rake cucumber mi dice: undefined method task.
Torno alla 1.8 :frowning:

non la 1.9, ma rake 0.9. Probabilmente lo hai installato e novo
quando hai migrato e ti sei beccato la versione nuova, che ha spostato
il DSL in un modulo diverso

Esattamente.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs