Ruby watir on Win2008R2

is this possible? i’m running in to LoadErrors and i’ve done all of
the things that are suppose to get around this problem…

On Aug 4, 5:10 pm, debuke [email protected] wrote:

is this possible? i’m running in to LoadErrors and i’ve done all of
the things that are suppose to get around this problem…

Please post the exact error you’re getting, with backtraces and
everything.

Include your installation steps and the more information as is
possible to you.

Help us help you.

we are running our scripts fine on windows server 2003 (standard) and
we are moving to windows server 2008R2 (standard).

we are using ruby 1.8.6, rubygems 1.3.4 with the following gems:

activesupport (2.3.2, 2.2.2)
archive-tar-minitar (0.5.2)
builder (2.1.2)
color (1.4.0)
commonwatir (1.6.2)
diff-lcs (1.1.2)
etc (0.2.0)
firewatir (1.6.2)
fxri (0.3.6)
fxruby (1.6.19, 1.6.12)
hoe (1.8.2)
hpricot (0.6.164)
pdf-reader (0.7.5)
pdf-toolkit (0.49)
pdf-writer (1.1.8)
rake (0.8.7, 0.8.4)
rspec (1.1.11)
rubyforge (1.0.4, 1.0.3)
rubyzip (0.9.1)
s4t-utils (1.0.4)
safariwatir (0.3.7)
transaction-simple (1.4.0)
user-choices (1.1.6)
watir (1.6.2)
win32-api (1.4.0)
win32-clipboard (0.4.3)
win32-dir (0.3.2)
win32-eventlog (0.4.6)
win32-process (0.6.0)
windows-api (0.3.0)
windows-pr (1.0.2)
xml-simple (1.0.12)

the error is occurring right at the start of our script and is:

C:\RgnScripts\AutomationTestScripts\RegressionTestCases>ruby
MaintMenu.rb
MaintMenu.rb:1:in `require’: no such file to load – watir (LoadError)
from MaintMenu.rb:1

setting RUBYOPT doesn’t seem to help either… :frowning:

note: i reiterate: the scripts work fine on 2003… :frowning:

well… to answer my own question… YES: ruby with watir is possible
on 2008R2…

turns out, we had a developer who made modifications to the ruby
scripts without me knowing it. once i applied those scripts all is
well…

sorry for the wasted time but thx for the help!

On Aug 5, 1:15 pm, debuke [email protected] wrote:

diff-lcs (1.1.2)
rspec (1.1.11)
win32-eventlog (0.4.6)
from MaintMenu.rb:1

setting RUBYOPT doesn’t seem to help either… :frowning:

setting to RUBYOPT=rubygems ?

what this produces?

ruby -rubygems -ve “require ‘watir’”

note: i reiterate: the scripts work fine on 2003… :frowning:

It works because it has something installed that this new 2008 machine
doesn’t.

We need to understand were the difference lies.

Unless you copied the whole Ruby folder and machine registry it will
not be the same.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs