[ruby-trunk - Bug #9062][Open] lib/rexml/parsers/streamparser.rb に require "rexml/parsers/baseparser

Issue #9062 has been reported by ohai (Ippei Obayashi).


Bug #9062: lib/rexml/parsers/streamparser.rb に require
“rexml/parsers/baseparser” を追加してほしい
https://bugs.ruby-lang.org/issues/9062

Author: ohai (Ippei Obayashi)
Status: Open
Priority: Normal
Assignee:
Category: lib
Target version:
ruby -v: ruby 2.1.0dev (2013-10-29 trunk 43466) [x86_64-linux]
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN

lib/rexml/parsers/streamparser.rb は内部で REXML::Parsers::BaseParser
を使っていますが
rexml/parsers/baseparser を require していません。そのため StreamParser を使うとき
rexml/parsers/streamparser に加えて rexml/parsers/baseparser を require
する必要があります。

面倒ですし streamparser.rb が baseparser を require するとよいと思うのですがどうでしょうか。

Issue #9062 has been updated by hsbt (Hiroshi SHIBATA).

Assignee set to kou (Kouhei S.)
Target version set to current: 2.1.0


Bug #9062: lib/rexml/parsers/streamparser.rb に require
“rexml/parsers/baseparser” を追加してほしい
https://bugs.ruby-lang.org/issues/9062#change-42668

Author: ohai (Ippei Obayashi)
Status: Open
Priority: Normal
Assignee: kou (Kouhei S.)
Category: lib
Target version: current: 2.1.0
ruby -v: ruby 2.1.0dev (2013-10-29 trunk 43466) [x86_64-linux]
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN

lib/rexml/parsers/streamparser.rb は内部で REXML::Parsers::BaseParser
を使っていますが
rexml/parsers/baseparser を require していません。そのため StreamParser を使うとき
rexml/parsers/streamparser に加えて rexml/parsers/baseparser を require
する必要があります。

面倒ですし streamparser.rb が baseparser を require するとよいと思うのですがどうでしょうか。

Issue #9062 has been updated by kou (Kouhei S.).

たしかにそのとおりですね!
追加しました!

Bug #9062: lib/rexml/parsers/streamparser.rb に require
“rexml/parsers/baseparser” を追加してほしい
https://bugs.ruby-lang.org/issues/9062#change-42679

Author: ohai (Ippei Obayashi)
Status: Closed
Priority: Normal
Assignee: kou (Kouhei S.)
Category: lib
Target version: current: 2.1.0
ruby -v: ruby 2.1.0dev (2013-10-29 trunk 43466) [x86_64-linux]
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN

lib/rexml/parsers/streamparser.rb は内部で REXML::Parsers::BaseParser
を使っていますが
rexml/parsers/baseparser を require していません。そのため StreamParser を使うとき
rexml/parsers/streamparser に加えて rexml/parsers/baseparser を require
する必要があります。

面倒ですし streamparser.rb が baseparser を require するとよいと思うのですがどうでしょうか。

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs