Ruby/Tk and rubyscript2exe problem

Hello, I am trying to compile a standalone exe file from a program
that I have written using ruby/tk. It runs completely fine from the
command line, but when I try to compile it I get the a message stating
that there is a problem in “…ruby/lib/ruby/1.8/tk.rb:1102”
specifically

“tcltklib:fail to Tk.Init(). invalid command name “tcl_findLibrary”
(RuntimeError)”

thus when I try to run the program it says that there is no gem “tk”
to load and it does not run. Any suggestions on how to fix this?

Brian

Tried this?
rubyscript2exe mycoolprogram.rbw --rubyscript2exe-tk
–rubyscript2exe-rubyw

Gregor

Yes I have tried using the “rubyscript2exe mycoolprogram.rbw
–rubyscript2exe-tk --rubyscript2exe-rubyw” setup, but it doesn’t
really seem to make a difference. It still runs into problems when it
tries to read the file tk.rb, so I assume that the problem is there.
I suppose I could just try adding Tk.Init() to the tk.rb file, but I
wasn’t sure if that would help.

Brian

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs