Ruby syntax highlighting problem with Emacs


#1

I was attempting to install ruby support into my emacs installation by
following the directions at the RubyGarden. When I load a ruby file,
Emacs switches to Ruby mode but doesn’t do syntax highlighting. Does
anybody have any insight? Here is the relevant portion of my .emacs
file:

(autoload 'ruby-mode “ruby-mode”
“Mode for editing ruby source files”)
(add-to-list 'auto-mode-alist ‘("\.rb\’" . ruby-mode))
(add-hook 'ruby-mode-hook 'turn-on-font-lock) ;; <- Is supposed to
enable font lock.

(setq interpreter-mode-alist (append '(("^#!.*ruby" . ruby-mode))
interpreter-mode-alist))

(setq ruby-indent-level 4)

I do not have ruby-electric.el installed, for the interested. Thank
you.

-Rich


#2

On Fri, Jan 06, 2006 at 01:35:38PM +0900, Rich wrote:

When I load a ruby file, Emacs switches to Ruby mode but doesn’t do
syntax highlighting. Does anybody have any insight?

Perhaps you need to turn syntax highlighting on in general:

(global-font-lock-mode 1)


#3

That did it. Thank you very much.