Ruby script console error in edge version


#1

Hi,

I try to play with edge version of rails. Maybe someday I could be
rails contributor. :slight_smile:
Ok, based on rails recipe books by martin, I do this:
$ rails example_rails_hack (I have rails 1.2 version)
$ cd example_rails_hack/vendor
$ svn co http://svn.rubyonrails.org/rails/trunk rails

The fast way to play with this edge version is through console. So…
$ cd …
$ ruby script/console

But I got this error:
Loading development environment.
/home/knight/work/code/ruby/example_rails_hack/vendor/rails/
activerecord/lib/…/…/activesupport/lib/active_support/
dependencies.rb:477:in const_missing':NameError: uninitialized constant ActionController::Base::DEPRECATED_INSTANCE_VARIABLES /home/knight/work/code/ruby/example_rails_hack/app/controllers/ application.rb:6:NoMethodError: undefined methodsession’ for
ApplicationController:Class

Any idea how to fix this?

Thank you.