Ruby-postgres 0.8.0 [RC]


#1

Hello,

For the ruby-postgres users out there, I would like to announce the
coming of a 0.8.0 release. First, some wider spread testing would be
a good idea. The current gem is version 0.7.1.2005.11.27. This is
basically 0.8.0 RC1 (can you do “RC1” type versioning with gems?).

What’s new:

  • bug and leak fixes (get_notify works)
  • bind parameters (postgresql uses $1, $2, etc)
  • Win32 binary gem
  • results translated to ruby classes (old behavior of string results
    is available with PGconn::translate_results = false)
  • rows are: PGrow < Array; behave like hash, ex row[‘id’] or row.each
    {|column,value| …} and provides to_hash method
  • rdocs (more work needed)
  • simplified build
  • open/connect/new with connection string or hash

New methods:

  • escape_bytea/unescape_bytea
  • on_notice
  • transaction_status
  • server_version, protocol_version
  • lastval (only available when connected to postgresql >= 8.1)
  • oid

feel free to let me know if you find any bugs. feature requests are
welcome.

Dave


#2

Is this a pure ruby implementation or does it have a dependancy on a
postgres client library ?

j.

On 11/29/05, Dave L. removed_email_address@domain.invalid wrote:

  • bug and leak fixes (get_notify works)
    New methods:

Dave


“Remember. Understand. Believe. Yield! -> http://ruby-lang.org

Jeff W.


#3

Jeff W. removed_email_address@domain.invalid writes:

Is this a pure ruby implementation or does it have a dependancy on a
postgres client library ?

This is the version that use libpq.
Thanks Dave L. for taking over maintainance!

YS.