Ruby OpenSSL issues

I am trying to update ruby on my mac and keep getting an issue with
openssl. I have this posted on StackOverflow so if you can answer it you
can get some points over there too.

Using rvm I upgraded my ruby to 1.9.3-p392, also added 2.0.0, anytime I
try to use this version when I run my bundle command I get this error.

Could not load OpenSSL.
You must recompile Ruby with OpenSSL support or change the sources in
your Gemfile from ‘https’ to ‘http’. Instructions for compiling with
OpenSSL using RVM are
available at rvm.io/packages/openssl.

I have followed several different instructions on how to fix this. I
have tried removing the version and installing it with the rvm options

–with-openssl-dir=$HOME/.rvm/usr

I have installed OpenSSL with rvm, and macports. Both have not helped
the problem. I even changed the file location of the ssl cert using
this:

export SSL_CERT_FILE=/Users/DarkLord/.rvm/usr/ssl/cert.pem

$ openssl version
OpenSSL 1.0.1e 11 Feb 2013

$ which openssl
/opt/local/bin/openssl

check my post - and build your ruby as I described

http://tom.meinlschmidt.org/2012/05/07/ruby-1-9-3-seg-fault-fix/

tom

On Mar 5, 2013, at 0:42 , Curtis O. [email protected] wrote:

–with-openssl-dir=$HOME/.rvm/usr


You received this message because you are subscribed to the Google G. “Ruby
on Rails: Talk” group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected]
To post to this group, send email to [email protected]
For more options, visit https://groups.google.com/groups/opt_out.

Tomas Meinlschmidt, MS {MCT, MCP+I, MCSE, AER}, NetApp Filer/NetCache

www.meinlschmidt.com www.maxwellrender.cz

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs