Ruby Openssl error / Webrick

Hi There, I’m getting the following errors while starting webrick.
I’m using (ruby 1.8.7 (2008-06-20 patchlevel 22) [i686-linux]), Rails
2.1.0, and Gem 1.2.0.
I’m using the same in my local server and its working perfectly.

=> Booting WEBrick…
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/initializer.rb:
225:in require_frameworks': no such file to load -- openssl (RuntimeError) from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/ initializer.rb:113:inprocess’
from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/
initializer.rb:93:in send' from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/ initializer.rb:93:inrun’
from /var/www/vhosts/polycore.in/Rubyproject/abc/config/
environment.rb:13
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:inrequire’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/
active_support/dependencies.rb:509:in require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/ active_support/dependencies.rb:354:innew_constants_in’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/
active_support/dependencies.rb:509:in require' from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/ commands/servers/webrick.rb:59 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:ingem_original_require’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/ active_support/dependencies.rb:509:inrequire’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/
active_support/dependencies.rb:354:in new_constants_in' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/ active_support/dependencies.rb:509:inrequire’
from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/
commands/server.rb:39
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:inrequire’
from script/server:3

Please help me what should I do resolve this.
Thanks to all
Mohd Anas

On 20 Aug 2008, at 15:23, mohdanas wrote:

Hi There, I’m getting the following errors while starting webrick.
I’m using (ruby 1.8.7 (2008-06-20 patchlevel 22) [i686-linux]), Rails
2.1.0, and Gem 1.2.0.
I’m using the same in my local server and its working perfectly.

You need the ruby openssl libraries (eg libopenssl-ruby1.8 on ubuntu)

Fred

Thanks For reply,
I am using CentOS5.

On Aug 20, 7:28 pm, Frederick C. [email protected]

Thanks Fred for all your support.
I got this problem solved by installing openssl-devel packages
and reconfigure all the ruby packages from scratch.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs