Ruby-opengl on Mac OS X

All: Pardon this noobish question. I’m trying to bring up ruby-opengl
on my Mac OS X (v 10.4.10).

I ran “sudo gem install ruby-opengl” without any trouble – gem
announced that it was loading ruby-opengl 0.40.1 as well as mkrf-0.2.2
– so far so good! I poked around and found that it had installed the
following file (among others):

/usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/opengl.rb

This looks hopeful. In irb, I typed:

irb(main):106:0> require ‘opengl’

which resulted in:

LoadError: no such file to load – opengl
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from (irb):106
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:399

My question: My guess is this is a problem with paths. What is the
cleanest remedy? Do I extend my path, make symbolic links, or move the
opengl files?

Thanks.

  • ff

On Thu, Sep 20, 2007 at 01:31:38PM +0900, Robert P. wrote:

This looks hopeful. In irb, I typed:
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require’
from (irb):106
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:399

My question: My guess is this is a problem with paths. What is the
cleanest remedy? Do I extend my path, make symbolic links, or move the
opengl files?

I think you want to require ‘gl’ rather than ‘opengl’. With a working
install of ruby-opengl on 10.4.10 I have the following in a working Ruby
script:

require ‘rubygems’
require ‘gl’
require ‘glu’
require ‘glut’

You don’t need GLU or GLUT unless you’re using them, mind you.

Thanks.

  • ff
    –Greg

Gregory S. wrote:


I think you want to require ‘gl’ rather than ‘opengl’. With a working
install of ruby-opengl on 10.4.10 I have the following in a working Ruby
script:

require ‘rubygems’
require ‘gl’
require ‘glu’
require ‘glut’

You don’t need GLU or GLUT unless you’re using them, mind you.

–Greg

Greg:

Whoo hoo! It Just Works. Many thanks.

  • Rob

Hi,

/Volumes/TextMate1.5.5/TextMate.app/Contents/SharedSupport/Support/lib/
scriptmate.rb:107:in `initialize’: Permission denied -
/usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/examples/plane.rb
(Errno::EACCES) from /Volumes/TextMate

What am I doing wrong?

I think TextMate needs write access to files to run them (bug?). I had
the very same problem yesterday, even with a ‘properly’ installed
TextMate, and I ended up copying the example .rb files to the Desktop.
Could run them from there without problems.

Julian

Julian R. wrote:

Hi,

/Volumes/TextMate1.5.5/TextMate.app/Contents/SharedSupport/Support/lib/
scriptmate.rb:107:in `initialize’: Permission denied -
/usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/examples/plane.rb
(Errno::EACCES) from /Volumes/TextMate

What am I doing wrong?

I think TextMate needs write access to files to run them (bug?). I had
the very same problem yesterday, even with a ‘properly’ installed
TextMate, and I ended up copying the example .rb files to the Desktop.
Could run them from there without problems.

Julian

Ok, I copied an exmple rb file to the Desktop where TextMate is, but
still get:

LoadError: Failed to lookup Init function
/usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/gl.bundle

method require in custom_require.rb at line 32
at top level in gl-test.rb at line 46

???

BTW, my TextMate is a trial version.

Sy

Fearless F. wrote:

Gregory S. wrote:


I think you want to require ‘gl’ rather than ‘opengl’. With a working
install of ruby-opengl on 10.4.10 I have the following in a working Ruby
script:

require ‘rubygems’
require ‘gl’
require ‘glu’
require ‘glut’

You don’t need GLU or GLUT unless you’re using them, mind you.

–Greg

Greg:

Whoo hoo! It Just Works. Many thanks.

  • Rob

Hello, Greg and Rob, Sorry for my newbie question in advance.

I am in very similar situation as Rob was in: I installed
ruby-opengl-0.40.1
in OS X(v. 10.4.10), and found ‘opengl.rb’ and others in

/usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/opengl.rb

But when I do irb(main):003:0> require ‘gl’
I get the following error:

LoadError: Failed to lookup Init function ./gl.bundle
from ./gl.bundle
from (irb):2

(Well, ‘opengl.rb’ file contains line “require ‘gl’” anyway, but when I
do
irb(main):003:0> require ‘opengl’, I receive:
LoadError: Failed to lookup Init function ./gl.bundle
from ./gl.bundle
from ./opengl.rb:16
from (irb):1:in `require’
from (irb):1 )

I also tried to test run ‘plane.rb’ file located in
/usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/examples
using TextMate and got the following:

/Volumes/TextMate1.5.5/TextMate.app/Contents/SharedSupport/Support/lib/
scriptmate.rb:107:in `initialize’: Permission denied -
/usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/examples/plane.rb
(Errno::EACCES) from /Volumes/TextMate

What am I doing wrong?

Sy

On 10/12/07, Sy Yoon [email protected] wrote:

I think TextMate needs write access to files to run them (bug?). I had
/usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/gl.bundle

method require in custom_require.rb at line 32
at top level in gl-test.rb at line 46

???

BTW, my TextMate is a trial version.

Don’t know if it might be the same problem, but just in case. I was
trying to install opengl in Ubuntu, but couldn’t make it work, until
someone pointed to me that opengl.0.40.1 required version 1.9+ of
rubygems. So maybe you could try to upgrade to version 1.9 to see if
that’s the problem?

In Ubuntu:

sudo gem update --system

Don’t know how to do it in Mac OS X, though.

Hope this helps,

Jesus.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs