Ruby-opengl on a g4 mac 10.4

irb(main):001:0> require ‘rubygems’
=> true
irb(main):002:0> gem ‘ruby-opengl’
=> true
irb(main):003:0> require ‘gl’
LoadError: Failed to lookup Init function /usr/local/lib/ruby/gems/1.8/
gems/ruby-opengl-0.40.1/lib/gl.bundle
from /usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/
gl.bundle
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:32:in require' from (irb):3 irb(main):004:0> require 'glut' LoadError: Failed to lookup Init function /usr/local/lib/ruby/gems/1.8/ gems/ruby-opengl-0.40.1/lib/glut.bundle from /usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/ glut.bundle from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:32:inrequire’
from (irb):4
irb(main):005:0>

What dependencies should I look at in order to correct this problem?

I have the apple dev tools, x11, etc…

Thanks!

Hi,

I had the very same problem. Updating Rubygems fixed it for me.

Julian

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs