Ruby on Rails strange issue


#1

Hello,
I just installed Ruby on Rails and created the new repository.
I wanted to use Ruby on Rails with FCGI
The repository was created in /path/to/public_html

ls /path/to/public_html/ :
app cgi-bin config doc log public README script
tmp
asd components db lib logo.jpg Rakefile README_LOGIN test
vendor

I installed fcgi support for ruby on rails and mod_fastcgi for Apache
1.3.x using a guide from the rails wiki.
When I open in my browser http://domain.com/public I get a 404 error
saying:
[Thu Jun 1 07:07:03 2006] [error] [client IP] FastCGI: invalid
(dynamic) server “/path/to/public_html/dispatch.fcgi”: script not found
or unable to stat()

I am wondering why it searches for dispatch.fcgi in /path/to/public_html
if its located in /path/to/public_html/public ?

I tried and copied the contents of /path/to/public_html/public to
/path/to/public_html and after doing that I receive another error when
opening in my browser http://domain.com/public :

[Thu Jun 1 07:14:18 2006] [error] [client IP] FastCGI: comm with
(dynamic) server “/path/to/public_html/dispatch.fcgi” aborted: (first
read) idle timeout (30 sec)
[Thu Jun 1 07:14:18 2006] [error] [client IP] FastCGI: incomplete
headers (0 bytes) received from server
“/path/to/public_html/dispatch.fcgi”

I have Fedora Core 4
Apache 1.3.x
Rails 1.1.2
ruby 1.8.4
Gem 0.8.11
mod_fastcgi-SNAP-0404142202 (the latest)
fcgi devel compiled from sources 2.4.0
FastCGI ruby binding fcgi (0.8.6.1)
MySQL-server-4.1.12-1
MySQL/Ruby - mysql (2.7)

Please help
Thank you