Ruby on rails ecommerce tests are failing, but why?

i am working through the Beginning Ruby on Rails Ecommerce book and on
page 101 where it is talking about integration tests, i run
test/integration/book_test.rb and it fails giving me the following
error message:

  1. Failure:
    [test/integration/book_test.rb:45:in add_book' test/integration/book_test.rb:11:intest_book_administration’

expected tag, but no tag found matching {:content=>“Ruby for Dummies”,
:tag=>“td”} in:
href=”/stylesheets/style.css?1164206463" media=“screen”
rel=“Stylesheet” type=“text/css” />\n\t\n\t\n\t\t<div
id=“header”>\n\t\t\t<h1 id=“logo”>Emporium™\n\t\t\t<h2
id=“slogan”>Books on Rails\n\t\t\n\n\t\t<div

  • <a
    href="/admin/author">Authors | 
  • \n\t\t\t\t
  • <a
    href="/admin/publisher">Publishers | 
  • \n\t\t\t\t
  • <a
    href="/admin/book">Books | 
  • \n\t\t\t\t
  • <a
    href="/">Catalog | 
  • \n\t\t\t\t
  • <a
  • \n\t\t\t
id=“notice”>\n\t\t\t\tBook was successfully


\n\n\n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n\n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n\n
TitlePublished atIsbnBlurbPriceCreated atUpdated at
Ruby for DummiesMon Dec 04 09:27:30 CST 2006123-123-123-XThe best book released since "Eating for Dummies"40.4Mon Dec 04 09:27:30 CST 2006Mon Dec 04 09:27:30 CST 2006ShowEditDestroy
\n\n\n \n\n
\n\nNew book\n\n\t\t\n\n\t\t
© 1995-2006 Emporium
\n\t\n\n". is not true.

looking through the code, i clearly see that “Ruby for Dummies” is in
fact in there and I also see that it is wrapped inside of “td” html
tags… so why is this test failing? i thought there might have been a
typo in my code somewhere, so i downloaded the sample code from the
site and i still got the same error message.

i’m new to TDD so i’m not really sure where to start troubleshooting