Ruby Newbie

Good Day! I am attempting to install Jobsworth on FreeBSD 8.1-RELEASE
(amd64). It requires Ruby 1.9.x.

I attempted to install Ruby and applicable gems via the FreeBSD ports
collection. Suffice to say that this procedure did not work. :slight_smile: My
next step was RTFM…

In following the instructions at https://github.com/ari/jobsworth#readme
http://www.google.com/url?sa=D&q=https://github.com/ari/jobsworth%23readme
, I was able to get much further in the installation process!

I was able to get to Step 5 (Ruby gems). The only way I could get Step
5 (Ruby gems) to complete was to run the command as root although the
instructions wanted the commands run as my Apache user.

When I run Step 6 (Setup configuration and database) and initialize the
database schema, I get:
Initialize database schema [n]: y
Initializing database schema
(in /usr/local/www/jobsworth)
rake aborted!
no such file to load – iconv
/usr/local/www/jobsworth/Rakefile:4:in <top (required)>' (See full trace by running task with --trace) (in /usr/local/www/jobsworth) rake aborted! no such file to load -- iconv /usr/local/www/jobsworth/Rakefile:4:in<top (required)>’
(See full trace by running task with --trace)

Loading Rails to create account…
/usr/local/rvm/gems/ruby-1.9.2-p180/gems/json-1.4.6/lib/json/common.rb:
2:in require': no such file to load -- iconv (LoadError) from /usr/local/rvm/gems/ruby-1.9.2-p180/gems/json-1.4.6/lib/json/common.rb:2:in<top (required)>’
from
/usr/local/rvm/gems/ruby-1.9.2-p180/gems/json-1.4.6/lib/json.rb:1:in
require' from /usr/local/rvm/gems/ruby-1.9.2-p180/gems/json-1.4.6/lib/json.rb:1:in<top (required)>’
from
/usr/local/rvm/gems/ruby-1.9.2-p180/gems/bundler-1.0.10/lib/bundler/runtime.rb:68:in
require' from /usr/local/rvm/gems/ruby-1.9.2-p180/gems/bundler-1.0.10/lib/bundler/runtime.rb:68:inblock (2 levels) in require’
from
/usr/local/rvm/gems/ruby-1.9.2-p180/gems/bundler-1.0.10/lib/bundler/runtime.rb:66:in
each' from /usr/local/rvm/gems/ruby-1.9.2-p180/gems/bundler-1.0.10/lib/bundler/runtime.rb:66:inblock in require’
from
/usr/local/rvm/gems/ruby-1.9.2-p180/gems/bundler-1.0.10/lib/bundler/runtime.rb:55:in
each' from /usr/local/rvm/gems/ruby-1.9.2-p180/gems/bundler-1.0.10/lib/bundler/runtime.rb:55:inrequire’
from
/usr/local/rvm/gems/ruby-1.9.2-p180/gems/bundler-1.0.10/lib/bundler.rb:120:in
require' from /usr/local/www/jobsworth/config/application.rb:7:in<top
(required)>’
from internal:lib/rubygems/custom_require:29:in require' from <internal:lib/rubygems/custom_require>:29:inrequire’
from /usr/local/www/jobsworth/config/environment.rb:2:in <top (required)>' from <internal:lib/rubygems/custom_require>:29:inrequire’
from internal:lib/rubygems/custom_require:29:in require' from setup.rb:181:in’

I have attempted:

http://www.v25media.com/blog/read/forcing_ruby_1_9_2_via_rvm_to_use_iconv

http://blog.dev001.net/post/2436585997/installing-iconv-using-bundler-on-freebsd

Each of these refer to installing ruby using the --with-iconv-dir
option. I have tried the following commands after ‘rvm package install
iconv’:

rvm install --trace 1.9.2 -C
–with-iconv-dir=/usr/local/rvm/src/libiconv-1.13.1

rvm install --trace 1.9.2 -C --with-iconv-dir=$HOME/.rvm/usr

rvm install --trace 1.9.2 --C --with-iconv-dir=/usr/local/lib

None have worked. I fear I am missing something simple. Alas, I have
zero Ruby experience prior to this project. Any assistance would be
greatly appreciated!!! :slight_smile:

Thank You In Advance!

glenn

use rvm over ports for something like this. works well in jails in
freebsd as well.

Thank You for your time Stu. I am using rvm instead of ports. rvm
seems to be a bit more flexible…

I wound up using the following command to install ruby with iconv:

rvm install --trace 1.9.2 -C --with-iconv-dir=/usr/local/rvm/usr

Thank you again for your assistance.

glenn

I use the system iconv from the ports which seems to work better than
rvm. Is rvm’s iconv work better with the dir change? I will be
providing wayne notes for freebsd when I have the time. So is your
issue fixed? was the --trace 1.9.2 -C
–with-iconv-dir=/usr/local/rvm/usr the fix?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs