Ruby modules - for opensuse - where do i get them

hello dear ruby experts

run opensuse with version 13.1

where do i get the following ruby modules / ingedients to run this
programme…

require ‘open-uri’
require “net/http”
require ‘rexml/document’

def query_overpass(object_type, left,bottom,right,top, key, value)
base_url = "http://www.overpass-api.de/api/xapi?"
query_string =
“#{object_type}[bbox=#{left},#{bottom},#{right},#{top}][#{key}=#{value}]”
url = “#{base_url}#{URI.encode(query_string)}”
resp = Net::HTTP.get_response(URI.parse(url))
data = resp.body
return data and so on and so forth

do i find them in a repo or should i install it with / trough the
software-installation-programme…

love to hear from you

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs