Ruby lib version (1.8.6) doesn't match executable version

I did a manual install of Ruby 1.8.6 from source. Now I’m getting an
error that says:

/usr/lib/ruby/1.8/x86_64-linux/rbconfig.rb:7: ruby lib version (1.8.6)
doesn’t match executable version (1.8.5) (RuntimeError)
from /usr/local/lib/site_ruby/1.8/rubygems.rb:10:in require' from /usr/local/lib/site_ruby/1.8/rubygems.rb:10 from /usr/bin/rake:9:inrequire’
from /usr/bin/rake:9

The stack trace from Rails (it’s a rake task) points to rbconfig line 7:

module Config
RUBY_VERSION == “1.8.6” or
raise “ruby lib version (1.8.6) doesn’t match executable version
(#{RUBY_VERSION})”

ruby -v yields:

ruby 1.8.6 (2007-10-21 patchlevel 5000) [x86_64-linux]

Is it the patchlevel that’s throwing things off or is there something
else going on? The server in question is Ubuntu Feisty Fawn (7.04)

Thanks in advance.

Bah,turns out I just needed to reinstall rake and a few other gems.
Sorry for the chatter.

Vince W. wrote:

I did a manual install of Ruby 1.8.6 from source. Now I’m getting an
error that says:

/usr/lib/ruby/1.8/x86_64-linux/rbconfig.rb:7: ruby lib version (1.8.6)
doesn’t match executable version (1.8.5) (RuntimeError)
from /usr/local/lib/site_ruby/1.8/rubygems.rb:10:in require' from /usr/local/lib/site_ruby/1.8/rubygems.rb:10 from /usr/bin/rake:9:inrequire’
from /usr/bin/rake:9

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs