Ruby install - actionpack dependency?

I’m new to Ruby, so new in fact that I’m having problems with the
install. The homepage looks good, but the instructions don’t seem to
work for me. I’m trying this on Windows 2003 server.

I’ve downloaded Ruby and installed it, fine.
I’ve downloaded RubyGems and installed it, fine.

The next step is to run ‘gem install rails --include-dependencies’,
which doesn’t work. Originally I got an error about rails*.gem not
found, so I went to the Rubyforge and downloaded Rails 1.1.4 (although I
thought it would included in the original download - it is
RubyonRails.com). Then I retried the gem install rails, and got an error
that activesupport was a required dependency. I downloaded activesupport
from RubyForge, and activerecord, installed them both. I thought I was
back on track and could just proceed to do this for the other packages,
but not quite so simple…

The next dependency is ‘actionpack’ which must be greater than 1.12.3.
On RubyForge the latest version is 1.12.1, and I can’t find the newer
version anywhere. What now?

I know there is an ‘all in one install’ via InstantRails, but I’d like
to do the manual install as part of my learning experience. Can anyone
offer any help?

Regards,

Ed.

Ed Grigson wrote:

I’m new to Ruby, so new in fact that I’m having problems with the
install. The homepage looks good, but the instructions don’t seem to
work for me. I’m trying this on Windows 2003 server.

I’ve downloaded Ruby and installed it, fine.
I’ve downloaded RubyGems and installed it, fine.

The next step is to run ‘gem install rails --include-dependencies’,
which doesn’t work. Originally I got an error about rails*.gem not
found, so I went to the Rubyforge and downloaded Rails 1.1.4 (although I
thought it would included in the original download - it is
RubyonRails.com). Then I retried the gem install rails, and got an error
that activesupport was a required dependency. I downloaded activesupport
from RubyForge, and activerecord, installed them both. I thought I was
back on track and could just proceed to do this for the other packages,
but not quite so simple…

The next dependency is ‘actionpack’ which must be greater than 1.12.3.
On RubyForge the latest version is 1.12.1, and I can’t find the newer
version anywhere. What now?

I know there is an ‘all in one install’ via InstantRails, but I’d like
to do the manual install as part of my learning experience. Can anyone
offer any help?

Regards,

Ed.

Found it using Google, and finally have Rails installed. For anyone else
looking for it, you can find it at;
http://rubyforge.org/frs/?group_id=361&release_id=5827

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs