Ruby-gnome2 and fedora core 6

I installed a package built from ruby-gnome2-all (version 0.14.1) which
include libart and requires libart_lgpl-devel so the package seems to be
built correctly.
when i want to run alexandria i obtain this error :
/usr/lib/ruby/site_ruby/1.8/glib2.rb: line 44
GLib-GObject-CRITICAL **:g_boxed_type_register_static: assertion
g_type_from_name (name) == 0' failed /usr/lib/ruby/site_ruby/1.8/glib2.rb: line 44 GLib-GObject-CRITICAL **:g_param_spec_boxed: assertionG_TYPE_IS_BOXED (boxed_type)’ failed
/usr/lib/ruby/site_ruby/1.8/glib2.rb: line 44
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion
G_IS_PARAM_SPEC (pspec)' failed /usr/lib/ruby/site_ruby/1.8/glib2.rb: line 44 GLib-GObject-CRITICAL **:g_param_spec_boxed: assertionG_TYPE_IS_BOXED (boxed_type)’ failed
/usr/lib/ruby/site_ruby/1.8/glib2.rb: line 44
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion
G_IS_PARAM_SPEC (pspec)' failed /usr/lib/ruby/site_ruby/1.8/gnomecanvas2.rb:2:inrequire’: no such file
to load – libart2 (LoadError)
from /usr/lib/ruby/site_ruby/1.8/gnomecanvas2.rb:2
from /usr/lib/ruby/site_ruby/1.8/gnome2.rb:1:in require' from /usr/lib/ruby/site_ruby/1.8/gnome2.rb:1 from /usr/lib/ruby/site_ruby/1.8/alexandria/ui.rb:20:inrequire’
from /usr/lib/ruby/site_ruby/1.8/alexandria/ui.rb:20
from /usr/lib/ruby/site_ruby/1.8/alexandria.rb:92:in require' from /usr/lib/ruby/site_ruby/1.8/alexandria.rb:92 from /usr/bin/alexandria:7:inrequire’
from /usr/bin/alexandria:7

So i tried also to build ruby-gnome2-all but version 0.15.0 and i have
others errors about gtk :
$ alexandria
/usr/lib/ruby/site_ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_boxed_type_register_static: assertion
g_type_from_name (name) == 0' failed /usr/lib/ruby/site_ruby/1.8/glib2.rb: line 55 GLib-GObject-CRITICAL **:g_param_spec_boxed: assertionG_TYPE_IS_BOXED (boxed_type)’ failed
/usr/lib/ruby/site_ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion
G_IS_PARAM_SPEC (pspec)' failed /usr/lib/ruby/site_ruby/1.8/glib2.rb: line 55 GLib-GObject-CRITICAL **:g_param_spec_boxed: assertionG_TYPE_IS_BOXED (boxed_type)’ failed
/usr/lib/ruby/site_ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion
`G_IS_PARAM_SPEC (pspec)’ failed
/usr/bin/ruby: symbol lookup
error: /usr/lib/ruby/site_ruby/1.8/i386-linux/gtk2.so: undefined symbol:
GLIST2ARYF

Is 0.15.0 version too recent for alexandria ? What could be the problem
with 0.14.1 version ?

Thanks

Eric


Using Tomcat but need to do more? Need to support web services,
security?
Get stuff done quickly with pre-integrated technology to make your job
easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

Hi,

Did you try CVS version ?

Some GC problems have been fixed.

On Thu, 02 Nov 2006 08:46:58 +0100
Tanguy E. [email protected] wrote:

/usr/lib/ruby/site_ruby/1.8/glib2.rb: line 44
from /usr/lib/ruby/site_ruby/1.8/gnomecanvas2.rb:2

GLib-GObject-CRITICAL **:g_object_class_install_property: assertion

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642


ruby-gnome2-devel-en mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/ruby-gnome2-devel-en


Using Tomcat but need to do more? Need to support web services,
security?
Get stuff done quickly with pre-integrated technology to make your job
easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

Hi, i’m not very familiar with cvs.
Is there somewhere a tar.gz file of the cvs ?
Thanks

Eric

Le dimanche 05 novembre 2006 à 01:34 +0900, Masao M. a écrit :

include libart and requires libart_lgpl-devel so the package seems to be
`G_IS_PARAM_SPEC (pspec)’ failed
from /usr/lib/ruby/site_ruby/1.8/gnome2.rb:1
others errors about gtk :
/usr/lib/ruby/site_ruby/1.8/glib2.rb: line 55
with 0.14.1 version ?
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642


ruby-gnome2-devel-en mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/ruby-gnome2-devel-en


Using Tomcat but need to do more? Need to support web services,
security?
Get stuff done quickly with pre-integrated technology to make your job
easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

Hi,

On 11/4/06, Tanguy E. [email protected] wrote:

Hi, i’m not very familiar with cvs.
Is there somewhere a tar.gz file of the cvs ?

It’s easy to use the CVS client on Unix systems to download the latest
Ruby-GNOME2 from the CVS, which generally is in a good state and is
easy to compile and install. Here’s the receipt:

  1. First, install the CVS client. In Debian (Apt-get) systems, it’s a
    matter of “apt-get install cvs”.

  2. Then you can download the CVS repository by running the following
    commands in a terminal:

2.1. This one prepares the CVS connection to the server (no password
is needed, just press enter):

cvs
-d:pserver:[email protected]:/cvsroot/ruby-gnome2
login

2.2. This one downloads the repository:

cvs -z3
-d:pserver:[email protected]:/cvsroot/ruby-gnome2
co -P ruby-gnome2

  1. Enter the new Ruby-GNOME2 repository and compile and install it, by
    using the following commands:

cd ruby-gnome2
ruby extconf.rb
make
make install

That’s it. Notice that to compile Ruby-GNOME2 or its GTK+ wrapping
modules, you need some development libraries of GNOME2 or GTK+. To
install them on Debian based systems, it’s a matter of “apt-get
install libgtk2.0-dev gnome-devel”.

When you run “ruby extconf.rb”, it will detect the available
development libraries and compile the Ruby-GNOME2 modules which can be
compiled with those libraries. The process can ignore the Ruby-GNOME2
modules which can’t be compiled due to missing development libraries.
As long as you don’t need the ignored libraries, you should be fine.
Notice that Ruby-GNOME2 supports dozens of libraries, many of which we
rarely use, if at all. :slight_smile:

Notice that much of the process would be the same with the “tar.gz”
source package.

Cheers,
Joao


Using Tomcat but need to do more? Need to support web services,
security?
Get stuff done quickly with pre-integrated technology to make your job
easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs