Ruby - gems not


#1

Hi
I am trying to load Ruby and Gems on my laptop right from 24 hours. I
installed and uninstalled the whole modules, 3 times but of no use.
there is one error being thrownout when loading the gems.
But at the irb —it is says watir —true.
The unit tests dont run
The error is, after installing few files it says
ERROR: While generating documentaion builder - 2.1.2
MESSAGE : Unhandled special :Specoa;: type=17, test=""
–RDOC args : --ri --op C:?ruby/lib/gems/1.8/doc/builder-2.1.2/ri-title
Builder --Easy XML Building – main README --line-numbers–quite lib
Changes Ra
kefile README
doc/releaes/builder-1.2.44.rdoc/releases/builder-2.0.0.rdoc do
c/releaes/builder-2.1.1.rdoc
<continuing with the rest of the installation?
and it continues installing

i prompted gem updated
but gives an ERROR : while executing gem…Failed to build gem native
extension

If anyone wants to see the sscreen shot please let me knw becoz the file
is saying too large to attach here

please help me to sort this out. I have to load this on Monday at work

thank you
Devi


#2

On Sun, Apr 19, 2009 at 5:53 AM, Devi R. removed_email_address@domain.invalid wrote:

Hi
Hello Devi,

I am trying to load Ruby and Gems on my laptop right from 24 hours. I
installed and uninstalled the whole modules, 3 times but of no use.

It’s unclear to me exactly what problem you’re trying to solve…

there is one error being thrownout when loading the gems.
But at the irb —it is says watir —true.

I’m not sure what you mean by that. Do you mean that ‘require
“watir”’ returns true? If so, that’s not an error.

The unit tests dont run

What unit tests? What is the error/failure reported when you run
these unit tests?

The error is, after installing few files it says
ERROR: While generating documentaion builder - 2.1.2
MESSAGE : Unhandled special :Specoa;: type=17, test=""
[…]

This won’t stop you from using the builder gem; at worst, you may be
missing some documentation for the builder gem on your local
machine.

i prompted gem updated
but gives an ERROR : while executing gem…Failed to build gem native
extension

Which gem is failing to build it’s native extension? Once you figure
that out, googling for that gem’s specific requirments will probably
tell you what you’re missing.

Also, it’d be useful to know what operating system and the versions of
ruby and rubygems you’re on.

cheers,
lasitha


#3

Thank you very much lasitha:
sorry i was not so clear
my windows version is vista, ruby version:1.8.6 , gems version: 1.3.2
The error is, after installing few files it says

ERROR: While generating documentaion builder - 2.1.2
MESSAGE : Unhandled special :Specoa;: type=17, test=""
[…]

This won’t stop you from using the builder gem; at worst, you may be
missing some documentation for the builder gem on your local
machine

I ignored this actually in the intial stages.but later when i am trying
to type in
ie=Watir::IE.new to intialize internet explorer for google search test
case, it was saying IE not found in the library. So i went to the gems
folder and opened each folder only to see that they dont have anyfiles
in it…I felt this error may be the reason that the irb is not
recognizing IE.It is giving the error
NameError:undefined local variable or method’watir’ for main:Object from
:02

Later i went to the SCite and typed in the whole test case to open the
IE and search for pickaxe, it is not throwing out any errors and shows
Exit code:0 but it doesnt open Internet explorer or is doing nothing.

when i click

lasitha wrote:

On Sun, Apr 19, 2009 at 5:53 AM, Devi R. removed_email_address@domain.invalid wrote:

Hi
Hello Devi,

I am trying to load Ruby and Gems on my laptop right from 24 hours. I
installed and uninstalled the whole modules, 3 times but of no use.

It’s unclear to me exactly what problem you’re trying to solve…

there is one error being thrownout when loading the gems.
But at the irb —it is says watir —true.

I’m not sure what you mean by that. Do you mean that ‘require
“watir”’ returns true? If so, that’s not an error.

The unit tests dont run

What unit tests? What is the error/failure reported when you run
these unit tests?

The error is, after installing few files it says
ERROR: While generating documentaion builder - 2.1.2
MESSAGE : Unhandled special :Specoa;: type=17, test=""
[…]

This won’t stop you from using the builder gem; at worst, you may be
missing some documentation for the builder gem on your local
machine.

i prompted gem updated
but gives an ERROR : while executing gem…Failed to build gem native
extension

Which gem is failing to build it’s native extension? Once you figure
that out, googling for that gem’s specific requirments will probably
tell you what you’re missing.

when i typed in again update …it didnt give me any errors or neither
the system install give me errors. So i think i am fine here.

Also, it’d be useful to know what operating system and the versions of
ruby and rubygems you’re on.

cheers,
lasitha