Ruby don't surf


#1

I’m getting the following error. I’ve looked all over, and have found
mentions of it, but nothing I’ve tried has worked. (I’ve reinstalled
everything several times now…)

irb

dyld: NSLinkModule() error
dyld: Symbol not found: _rb_io_stdio_file
Referenced from:
/usr/local/lib/ruby/site_ruby/1.8/powerpc-darwin8.6.0/readline.bundle
Expected in: flat namespace

Trace/BPT trap

Most recently I reinstalled everything using the instructions I found
here:

http://blade.nagaokaut.ac.jp/cgi-bin/vframe.rb?key=readline+NSLinkModule()+error&cginame=namazu.rb&submit=Search&dbname=ruby-talk&max=50&whence=0

(Reinstalling readline then running

make distclean && configure --with-readline-dir=/usr/local && make &&
make test-all

Which gave me an error about Tcl/Tk, so I ran it again like this:

make distclean && configure --with-readline-dir=/usr/local
–with-pthreads && make && make test-all

Now I get the following error:

making ruby
gcc -g -O2 -pipe -fno-common -DRUBY_EXPORT -L. main.o
-lruby-static -lpthread -ldl -lobjc -o ruby
./miniruby ./runruby.rb --extout=.ext – -C “./test” runner.rb
–runner=console
/Users/administrator/src/ruby/ruby/lib/test/unit/autorunner.rb:199:in
Test::Unit::AutoRunner#run': undefined method[]’ for :console:Symbol
(NoMethodError)
from
/Users/administrator/src/ruby/ruby/lib/test/unit/autorunner.rb:13:in
`Test::Unit::AutoRunner#run’
from runner.rb:9
make: *** [test-all] Error 1

Something is not configured correctly, but what?

Everything was working fine two days ago. Now I’ve lost two days and I’m
still nowhere. Does anyone have any idea what the problem might be? I’m
at my wit’s end.

Thanks for any help.

Chas. Munat
Seattle


#2

“C” == Charles F Munat removed_email_address@domain.invalid writes:

Well, probably I’m wrong

C> dyld: NSLinkModule() error
C> dyld: Symbol not found: _rb_io_stdio_file
^^^^^^^^^^^^^^^^
C> Referenced from:
C> /usr/local/lib/ruby/site_ruby/1.8/powerpc-darwin8.6.0/readline.bundle
^^^

but rb_io_stdio_file() is defined only in ruby-1.9, not in ruby-1.8

What is your version of ruby ?

Guy Decoux


#3

Ah! Good eyes. Somewhere along the line I had accidentally downloaded
1.9 from CVS. I found a copy of 1.8.4, untarred it, and repeated the
process. Tcl/Tk was still a problem, so I used --enable-pthreads. It
compiled, but make test-all gave the following failures:

Finished in 120.31191 seconds.

  1. Failure:
    test_delete(TestDBM) [./dbm/test_dbm.rb:332]:
    exception expected but none was thrown.

  2. Failure:
    test_s_open_error(TestSDBM) [./sdbm/test_sdbm.rb:123]:
    Errno::EACCES exception expected but none was thrown.

1313 tests, 14447 assertions, 2 failures, 0 errors
make: *** [test-all] Error 1

Any ideas as to what is causing these?

Thanks for the help.

Chas.


#4

Ignored the test failures and installed anyway. It seems to work now.

Thanks,
Chas.