Ruby DH openssl warning

I get the following warning when this code is run (extracted from
net/https)

require ‘timeout’
require ‘socket’
require ‘openssl’
s = timeout(10) { TCPSocket.open(‘mail.google.com’, ‘443’) }
ssl_context = OpenSSL::SSL::SSLContext.new
s = OpenSSL::SSL::SSLSocket.new(s, ssl_context)

warning: using default DH parameters.

Does anyone know how to resolve this? I know you have to setup some
pre-generated DH numbers on the context, but I haven’t seen any examples
how to do this.

thanks,
eric

On Aug 3, 2006, at 6:01 PM, Eric Kolve wrote:

warning: using default DH parameters.

Does anyone know how to resolve this? I know you have to setup some
pre-generated DH numbers on the context, but I haven’t seen any
examples
how to do this.

The OpenSSL library puts out a lot of warnings, and in most cases
there doesn’t seem to be a way to get rid of them. I don’t know if
I’ve specifically submitted a bug on this one, but I try to submit
bugs on cases where I find warnings that I can’t seem to get rid of.
It’s probably a good idea to submit a bug on this, since I can’t find
any evidence of harm and it’s pretty annoying getting this warning.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs