Ruby crashes with mshtml.dll

Hi,

I use Ruby 1.9.2.180 and it crashes several time with same error message
from event viewer. It comes and goes without any pattern and I have no
specific re-produced steps. It seems to be related to “mshtml.dll”. I
checked event viewer, and it say:

Faulting application ruby.exe, version 1.9.2.180, faulting module
mshtml.dll, version 8.0.6001.18702, fault address 0x0025ee8e.

I use watir to do web UI testing. I googled “mshtml.dll” and it is used
to handle IE layout. I try to use watir 1.8.0, 1.7.1, 1.6.7 and
ruby.exe still crashes with the same error message.

any idea?

Here is the Ruby gems I installed:
activesupport (2.3.9)
builder (3.0.0)
commonwatir (1.6.7)
firewatir (1.6.7)
hoe (2.9.1)
json_pure (1.5.1)
minitest (2.0.2, 1.6.0)
nokogiri (1.4.3.1 x86-mingw32)
racc (1.4.6)
rake (0.8.7)
rake-compiler (0.7.6)
rdoc (2.5.8)
rexical (1.0.5)
rubyforge (2.0.4)
s4t-utils (1.0.4)
test-unit (2.2.0)
user-choices (1.1.6.1)
watir (1.6.7)
win32-api (1.4.8)
win32-process (0.6.5)
windows-api (0.4.0)
windows-pr (1.1.3)
xml-simple (1.0.14)

Regards,
Paservan

On Mar 16, 2011, at 17:53 , Paservan NO wrote:

Faulting application ruby.exe, version 1.9.2.180, faulting module
mshtml.dll, version 8.0.6001.18702, fault address 0x0025ee8e.

I use watir to do web UI testing. I googled “mshtml.dll” and it is used
to handle IE layout. I try to use watir 1.8.0, 1.7.1, 1.6.7 and
ruby.exe still crashes with the same error message.

Isn’t that a problem with IE then?

Can you use firefox instead?

On Mar 16, 9:53pm, Paservan NO [email protected] wrote:

I use watir to do web UI testing. I googled “mshtml.dll” and it is used
to handle IE layout. I try to use watir 1.8.0, 1.7.1, 1.6.7 and
ruby.exe still crashes with the same error message.

any idea?

From water installation page:

http://watir.com/installation/

"Windows
Install Ruby
We recommend using Ruby 1.8.6 or 1.8.7 on all platforms.

Download and install the latest version of Ruby from
http://rubyinstaller.org/downloads
Note: Ruby 1.9.x does not work out-of-the-box with Watir, sorry."

Please try Ruby 1.8.7 and let us know.

Thanks for your reply

Hi Ryan D.,

I have to use IE browser because it is my testing purpose.

Hi Luis L.,

IPv6 is one of my testing purposes. That is why I upgrade ruby 1.8.6 to
1.9.2 which has better support for IPv6.

I try to reinstall win32-api according to your suggested. However, I get
the same win32-api-1.4.8-x86-mingw32.gem. My OS is windows XP SP3 x86.

C:\Documents and Settings\Administrator>gem uninstall win32-api --all

You have requested to uninstall the gem:
win32-api-1.4.8
windows-api-0.4.0 depends on [win32-api (>= 1.4.5)]
windows-pr-1.1.3 depends on [win32-api (>= 1.4.5)]
If you remove this gems, one or more dependencies will not be met.
Continue with Uninstall? [Yn] y
Successfully uninstalled win32-api-1.4.8

C:\Documents and Settings\Administrator>gem install win32-api
Fetching: win32-api-1.4.8-x86-mingw32.gem (100%)
Successfully installed win32-api-1.4.8-x86-mingw32
1 gem installed
Installing ri documentation for win32-api-1.4.8-x86-mingw32…
Installing RDoc documentation for win32-api-1.4.8-x86-mingw32…

I just found a pattern (it seems like a pattern, probably…). Mostly,
ruby crashes when it is trying to open socket to send a message to
remote side. However, it doesn’t crash every time it open a socket.

any idea?

Regards

On Mar 16, 9:53pm, Paservan NO [email protected] wrote:

Hi,

I use Ruby 1.9.2.180 and it crashes several time with same error message
from event viewer. It comes and goes without any pattern and I have no
specific re-produced steps. It seems to be related to “mshtml.dll”. I
checked event viewer, and it say:

I just attempted a clean 1.9.2-p180 installation, following the
installation instructions from watir website and using the examples
too:

http://watir.com/installation/
http://watir.com/examples/

C:\Users\Luis\Desktop>ruby --version
ruby 1.9.2p180 (2011-02-18) [i386-mingw32]

C:\Users\Luis\Desktop>gem --version
1.6.2

C:\Users\Luis\Desktop>gem list

*** LOCAL GEMS ***

builder (3.0.0)
commonwatir (1.8.0)
firewatir (1.8.0)
hoe (2.9.1)
nokogiri (1.4.4.1 x86-mingw32)
s4t-utils (1.0.4)
user-choices (1.1.6.1)
watir (1.8.0)
win32-api (1.4.8 x86-mingw32)
win32-process (0.6.5)
windows-api (0.4.0)
windows-pr (1.1.3)
xml-simple (1.0.14)

C:\Users\Luis\Desktop>type t.rb
require “rubygems”
require “watir”

browser = Watir::Browser.new
browser.goto(“http://bit.ly/watir-example”)

===

And worked without errors.

Something that is curious about your installation gems is win32-api.
In my case win32-api 1.4.8 was installed from binary form (1.4.8 x86-
mingw32) while in your case there is no platform binary mentioned.

For the sake of testing, can you remove the gem and install it again?

gem uninstall win32-api --all
gem install win32-api

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs