Ruby app through Heroku

I am trying to build a basic Ruby app on Twilio and deploying through
Heroku, I get an error. Backtracing it, when I check my Heroku logs, I
see the following:

C:\AJ\twilioapp>heroku logs
/usr/ruby1.8.7/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_orig inal_require': no such file to load -- sinatra (LoadError) from /usr/ruby1.8.7/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31 :inrequire’
from ./app.rb:1
from
/usr/ruby1.8.7/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31
:in gem_original_require' from /usr/ruby1.8.7/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31 :inrequire’
from config.ru:1

I did a quick search and tried running a ‘Hello World’ sinatra app and
it ran perfectly. Not sure why my Twilio is not working though.

Would you be kind enough to advise?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs