Ruby and OpenSSL: no such file to load -- openssl (RuntimeError)

I’m getting this error on Cygwin when trying to run this tiny little
Rails app:

./script/…/config/…/vendor/rails/railties/lib/initializer.rb:253:in
`require_frameworks’: no such file to load – openssl (RuntimeError)

I have both the openssl and openssl-devel packages installed. There’s
even an openssl.so in /lib/ruby/1.8/i386-cygwin. I don’t know about
libopenssl-ruby though, it only seems to exist for Debian and Ubuntu.

Anybody got a clue? Have a nice weekend y’all.

On Sat, Oct 18, 2008 at 3:28 PM, Redd V. [email protected]
wrote:

I’m getting this error on Cygwin when trying to run this tiny little Rails app:

./script/…/config/…/vendor/rails/railties/lib/initializer.rb:253:in
`require_frameworks’: no such file to load – openssl (RuntimeError)

I have both the openssl and openssl-devel packages installed. There’s
even an openssl.so in /lib/ruby/1.8/i386-cygwin. I don’t know about
libopenssl-ruby though, it only seems to exist for Debian and Ubuntu.

Anybody got a clue? Have a nice weekend y’all.

I just tried compiling/installing openssl-0.9.8i-1 manually, but that
didn’t work either.

On Sat, Oct 18, 2008 at 10:17 AM, Redd V. [email protected]
wrote:

Anybody got a clue? Have a nice weekend y’all.

I just tried compiling/installing openssl-0.9.8i-1 manually, but that
didn’t work either.

I’m no expert in this arena, but you may need to recompile ruby after
installing openssl.

HTH,
Michael G.

Yeah, good idea, but sorry, it made no difference.

Did you

(a) compile OpenSSL first and ensured that it worked

(b) then tried to compile the OpenSSL extension within the ext/ dir?

For me on Linux box this route always works.

What is the prefix of both ruby and openssl you use?

2008/10/18 Redd V. [email protected]:

I’m getting this error on Cygwin when trying to run this tiny little Rails app:

./script/…/config/…/vendor/rails/railties/lib/initializer.rb:253:in
`require_frameworks’: no such file to load – openssl (RuntimeError)

I have both the openssl and openssl-devel packages installed. There’s
even an openssl.so in /lib/ruby/1.8/i386-cygwin. I don’t know about
libopenssl-ruby though, it only seems to exist for Debian and Ubuntu.

Anybody got a clue? Have a nice weekend y’all.

Maybe you got your environment messed up. Did you try adding
/lib/ruby/1.8/i386-cygwin to RUBYLIB?

robert

On Sat, Oct 18, 2008 at 4:25 PM, Michael G. [email protected]
wrote:

I’m no expert in this arena, but you may need to recompile ruby after
installing openssl.

Yeah, good idea, but sorry, it made no difference.

Robert K. wrote:

Maybe you got your environment messed up. Did you try adding
/lib/ruby/1.8/i386-cygwin to RUBYLIB?

robert

Robert - thanks for the tip.
Setting it up via ‘export RUBYLIB=/lib/ruby/1.8/i386-cygwin’ did the
trick!

Jakub

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs