Ruby and lampp

Hello,

I have a problem whith my ruby configuration.

I explain :
I have lampp installed in my computer and I use Joomla AND Redmine

My /etc/hosts is like this:
127.0.0.1 localhost localhost.localdomain
85.31.216.211 www mywebsite

Joomla is configured on ‘mywebsite’ and I try to put redmine on
‘mywebsite’/redmine. That’s why I wrote the httpd.conf like :

LoadModule rewrite_module modules/mod_rewrite.so
########################################

RUBY SETUP

########################################
<VirtualHost *:80>
ServerName mywebsite/redmine
DocumentRoot “/opt/lampp/htdocs/redmine/public”
ProxyRequests Off
ProxyRequests On
ProxyVia On
<Proxy *>
Order deny,allow
Allow from all

ProxyPass / http://localhost:3000/
ProxyPassReverse / http://localhost:3000/

Order allow,deny Allow from all

<Directory “/opt/lampp/htdocs/redmine/public/”>

Options ExecCGI FollowSymLinks
AllowOverride all
Allow from all
Order allow,deny
AddHandler cgi-script .cgi
#AddHandler fastcgi-script .fcgi

########################################

RUBY SETUP

########################################

But it doesn’t work. Joomla is ok on ‘mywebsite’ but the url
‘mywebsite’/redmine isn’t found.

Please, does anyone know what I missed ?

Vio D. wrote:

Hello,

I have a problem whith my ruby configuration.

I explain :
I have lampp installed in my computer and I use Joomla AND Redmine

My /etc/hosts is like this:
127.0.0.1 localhost localhost.localdomain
85.31.216.211 www mywebsite

Joomla is configured on ‘mywebsite’ and I try to put redmine on
‘mywebsite’/redmine. That’s why I wrote the httpd.conf like :

LoadModule rewrite_module modules/mod_rewrite.so
########################################

RUBY SETUP

########################################
<VirtualHost *:80>
ServerName mywebsite/redmine
DocumentRoot “/opt/lampp/htdocs/redmine/public”
ProxyRequests Off
ProxyRequests On
ProxyVia On
<Proxy *>
Order deny,allow
Allow from all

ProxyPass / http://localhost:3000/
ProxyPassReverse / http://localhost:3000/

Order allow,deny Allow from all

<Directory “/opt/lampp/htdocs/redmine/public/”>

Options ExecCGI FollowSymLinks
AllowOverride all
Allow from all
Order allow,deny
AddHandler cgi-script .cgi
#AddHandler fastcgi-script .fcgi

########################################

RUBY SETUP

########################################

But it doesn’t work. Joomla is ok on ‘mywebsite’ but the url
‘mywebsite’/redmine isn’t found.

Please, does anyone know what I missed ?

Please, nobody can help me ??
I tried ProxyPass /redmine/ http://localhost:3000/
ProxyPassReverse /redmine/ http://localhost:3000/

instead of ProxyPass / http://localhost:3000/
ProxyPassReverse / http://localhost:3000/

but nothing happened

On Wed, Apr 16, 2008 at 5:13 PM, Vio D. [email protected] wrote:

127.0.0.1 localhost localhost.localdomain
ServerName mywebsite/redmine
ProxyPassReverse / http://localhost:3000/
Allow from all

instead of ProxyPass / http://localhost:3000/
ProxyPassReverse / http://localhost:3000/

but nothing happened

  1. I guess you have to run mongrel ore webrick on port 3000. Have you
    started it?
  2. This is most probably an Apache/Rails/Mongrel deployment problem,
    so you might get better help
    at either rails or mongrel lists.
    http://groups.google.com/group/rubyonrails-talk
    http://rubyforge.org/mail/?group_id=1306

ok thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs