Ruby and Eclipse


#1

Greetings!

I have been trying to get eclipse to where it can deal with ruby more or
less as it does with java. I am looking for some color coding, code
completion and, if possible, even debugging. So far, I am coming up
goose eggs. I have tried things that I saw on:

http://www.easyeclipse.org/site/distributions/ruby-rails.html
http://www-128.ibm.com/developerworks/opensource/library/os-rubyeclipse/
http://redmonk.com/sogrady/2006/01/19/eclips-ing-ruby/

but for some reason they do not work for me. Any tips from someone that
got it working?

Thanks,

Lloyd


#2

You might want to look at the DLTK plug-in if you are using Europa that
is.
Otherwise your best option is RDT which isn’t horrible but isn’t great.

On 5/7/07, Lloyd L. removed_email_address@domain.invalid wrote:

http://redmonk.com/sogrady/2006/01/19/eclips-ing-ruby/


“Hey brother christian with your high and mighty errand, Your actions
speak
so loud, I can’t hear a word you’re saying.”

-Greg Graffin (Bad Religion)


#3

Consider trying dltk for Ruby, they have a great type inference
(probably the best around to the date).

eclipse.org/dltk

On 07/05/07, Lloyd L. removed_email_address@domain.invalid wrote:

Greetings!

I have been trying to get eclipse to where it can deal with ruby more or
less as it does with java. I am looking for some color coding, code
completion and, if possible, even debugging. So far, I am coming up
goose eggs. I have tried things that I saw on:

This was freedom. Losing all hope was freedom.

Chasing the beauty in programming:
www.ruby-lang.org | www.rubyonrails.org


#4

I use Eclipse with RDT and RadRails on a Linux machine with no problems.
A little bulky and memory intense but is much more efficient than VIM
especially for Rails. My partner is on an XP machine and had problems
with the Eclipse/RDT/Rad setup so he found easyeclipse and it works fine
for him.

If you are having installation troubles, try describing those here or
posting to the respective mail-list.

On Tue, 2007-05-08 at 02:34 +0900, Lloyd L. wrote:

but for some reason they do not work for me. Any tips from someone that
got it working?

Thanks,

Lloyd

Thanks,

Ken M.
Wireless Operations Engineer
Farmers Wireless

CONFIDENTIALITY NOTICE: This e-mail and any attachment to it may contain
confidential and legally privileged information. This information is
intended only for the recipient named above. If you are not the intended
recipient, take notice that any disclosure, copying, distribution or
taking of any action based upon this information is prohibited by law.
If you have received this e-mail in error, please return it to the
sender and delete this copy from your system. Thank you.