Ruby 2.1.2 and Rails 4.1.4 on Windows 8.1

First, please don’t advise me to buy a Mac, install Linux or use a VM.
Windows 8.1 is a work requirement, and if I had one of those 3 (or
similar) options, I have done that by now. Thanks.

So is this even possible? I’ve tried to follow the instructions listed
at the following 2 sites to no avail:

http://madcoderspeak.blogspot.com/2009/06/how-to-compile-ruby-from-source-on.html

http://bunkernetz.com/2014/05/23/building-ruby-2-1-x64-on-windows-8/

When I try to invoke any of the Ruby commands, I get the follwoing error
msg:

`require’: cannot load such file – rubygems.rb (LoadError)

I know that I’m not only one because, I found many similar questions,
but they seem to go unanswered:

http://nerdanswer.com/answer.php?q=624763

Also if anyone knows when the Ruby 2.1.2 installer will be available
that would be good as well.