Ruby 2.0 gem problem, Symbol not found: _ruby_current_thread (LoadError)

Hi,

I am using netbeans/rubymine debug ruby program, installed

ruby-debug-base19x and debugger gem,
on ruby 1.9.3 , debug functional is ok.
Now, i am upgrade ruby to 2.0, clone that gems and change some thing
compatible ruby 2.0 C API,
https://github.com/windwiny/ruby-debug-base19
https://github.com/windwiny/debugger

The gem is can be compiled. But cannot require it.

ruby -e 'require “./ruby_debug” ’

/usr/local/homebrew/Cellar/ruby/2.0.0-p0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in
`require’:
dlopen(/usr/local/lib/ruby/gems/2.0.0/gems/debugger-1.3.3/ext/ruby_debug/ruby_debug.bundle,
9): Symbol not found: _ruby_current_thread (LoadError)
Referenced from:
/usr/local/lib/ruby/gems/2.0.0/gems/debugger-1.3.3/ext/ruby_debug/ruby_debug.bundle
Expected in: flat namespace
in
/usr/local/lib/ruby/gems/2.0.0/gems/debugger-1.3.3/ext/ruby_debug/ruby_debug.bundle

/usr/local/lib/ruby/gems/2.0.0/gems/debugger-1.3.3/ext/ruby_debug/ruby_debug.bundle
from
/usr/local/homebrew/Cellar/ruby/2.0.0-p0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in
require' from -e:1:in

anybody can help me?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs