Ruby 2.0.1 preview install problem

I’ve compiled Ruby 2.0.1preview1 but make install produces this:

ruby: invalid option --disable=gems (-h will show valid options)
make: *** [known_errors.inc] Error 2

How to fix?

gvim

That’s a bug. You’re prolly trying to bootstrap off of 1.8 and it
doesn’t support that flag.

This sucks, please report the bug to [email protected]

You can try building 1.9 first. Make sure it is installed to a location
in your path earlier than your stock ruby, then build 2.

On 08/10/2013 20:53, Ryan D. wrote:

That’s a bug. You’re prolly trying to bootstrap off of 1.8 and it doesn’t
support that flag.

This sucks, please report the bug to [email protected]

You can try building 1.9 first. Make sure it is installed to a location in your
path earlier than your stock ruby, then build 2.

It’s not quite so straightforward as I installed successfully on a - to
my knowledge - identical setup on my Macbook Pro running 10.8. The error
was from an installation on a Mac desktop running 10.8. Both machines
have the following setup:

  • rbenv and ruby-build installed via MacPorts
  • build dir for ruby 2.1 is $HOME/.rbenv/dev
  • configure --prefix=/sw required gobjcopy and friends so installed
    binutils on the desktop. Already installed on Macbook
  • both machines running ruby 2.0.0p247 installed via rbenv

gvim

On 08/10/2013 20:53, Ryan D. wrote:

That’s a bug. You’re prolly trying to bootstrap off of 1.8 and it doesn’t
support that flag.

This sucks, please report the bug to [email protected]

You can try building 1.9 first. Make sure it is installed to a location in your
path earlier than your stock ruby, then build 2.

Fixed. Thanks. Digging deeper, the PATH setup was slightly different on
each machine.

gvim

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs