Ruby 1.92 and hpricot gem

Would like to know if hpricot gem works on Ruby 1.92. I am trying to
install hpricot and getting an error - extconf.rb failedCould not creat
Makefile due to some reason. you may need configuration options. I tried
to install Ruby 1.87 still get the same error. I installed some dev kits
as suggested by some posts. No luck. Any idea how I can get this to work
please?

What OS are you installing on? From my experience, if it’s ubuntu,
there’s a few other libs you’ll need to install.

Or it could be that you don’t have proper permissions to write to
wherever…

How about posting the actual error string?

On Oct 25, 6:40pm, grace <[email protected]/> wrote:

Would like to know if hpricot gem works on Ruby 1.92. I am trying to install
hpricot and getting an error - extconf.rb failedCould not creat Makefile due to
some reason. you may need configuration options. I tried to install Ruby 1.87
still get the same error. I installed some dev kits as suggested by some posts. No
luck. Any idea how I can get this to work please?

Hello Grace,

Please provide the full information of your Ruby installation as
information about where you got it, where was installed, etc.

Also, provide the exact error message, copy and paste directly.

From what I can read seems you’re running Windows, RubyInstaller 1.9.2
and supposed to have DevKit installer.

If that is the case, please follow the installation instructions:

http://github.com/oneclick/rubyinstaller/wiki/Development-Kit

And read some tutorials about it:

http://github.com/oneclick/rubyinstaller/wiki/Tutorials

Most of the time there is something affecting your environment, but
for that we need the precise information.

Help us help you.

PS: When posting, try to give more space to paragraphs and sentences,
helps a lot with readability.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs