Ruby 1.9 / rails 2.0.2 problem

just now i installed ruby 1.9 and rails 2.0.2 on it

when i create new rails application

[email protected]:~/project$ rails app
can’t convert Enumerable::Enumerator into Array
[email protected]:~/project$

how to solve it ? or did i make any mistake in installation process?

run rails in 1.8.6 not 1.9

blj wrote:

run rails in 1.8.6 not 1.9

Agreed. I just upgraded to 1.9 and found all my applications totally
hosed. I had to delete 1.9 and reinstall 1.8.6, along with Ruby Gems (on
Leopard).

I’ll be waiting for the official announcement of compatibility on the
Rails blog.

On 26 Dec 2007, at 09:25, Daniel W. wrote:

Rails blog.
People are working on 1.9 compatibility, but 2.0.2 definitely isn’t
compaible, and edge rails isn’t there yet either (although plenty of
progress has been made towards that goal.
In general 1.9.0 isn’t production ready quite yet.

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs