Ruby 1.9 Installation Woes

I am trying to install ruby 1.9 on my mac (system details below).

HOWEVER, I keep getting an ld error with ./libruby19-static.a! I
understand what it’s saying but i don’t know how to fix it.

Hopefully someone has run into this before:

% make


/usr/bin/ld: archive: ./libruby19-static.a has no table of contents,
add one with ranlib(1) (can’t load from it)
collect2: ld returned 1 exit status
make[1]: *** [ruby19] Error 1
make: *** [all] Error 2
%

I have n0 clue why this is happening.

System Report:
Darwin
PPC
Mac OS 10.4.11
Ruby 1.8.6 installed perfectly fine from source
==> ruby 1.8.6 (2007-11-14 patchlevel 5000) [powerpc-darwin8.10.0]

Please let me know if I can help you help me!

Thanks,
Ari

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs