Ruby 1.9.3 causes rbuf_fill timeout, but 1.8.7 does not

subject line says it all. I am trying to use the Google Storage gem
(gstore), and if i use ruby 1.8.7, no problem. If i try to use ruby
1.9.3, i get this error:

Timeout::Error: Timeout::Error
from /usr/local/lib/ruby/1.9.1/net/protocol.rb:146:in rescue in rbuf_fill' from /usr/local/lib/ruby/1.9.1/net/protocol.rb:140:inrbuf_fill’
from /usr/local/lib/ruby/1.9.1/net/protocol.rb:122:in
readuntil' from /usr/local/lib/ruby/1.9.1/net/protocol.rb:132:inreadline’
from /usr/local/lib/ruby/1.9.1/net/http.rb:2562:in
read_status_line' from /usr/local/lib/ruby/1.9.1/net/http.rb:2551:inread_new’
from /usr/local/lib/ruby/1.9.1/net/http.rb:1319:in block in transport_request' from /usr/local/lib/ruby/1.9.1/net/http.rb:1316:incatch’
from /usr/local/lib/ruby/1.9.1/net/http.rb:1316:in
transport_request' from /usr/local/lib/ruby/1.9.1/net/http.rb:1293:inrequest’
from /usr/local/lib/ruby/gems/1.9.1/gems/gstore-0.2.1/lib/
gstore/request.rb:94:in block in _http_do' from /usr/local/lib/ruby/1.9.1/net/http.rb:745:instart’
from /usr/local/lib/ruby/gems/1.9.1/gems/gstore-0.2.1/lib/
gstore/request.rb:86:in _http_do' from /usr/local/lib/ruby/gems/1.9.1/gems/gstore-0.2.1/lib/ gstore/request.rb:71:insigned_request’
from /usr/local/lib/ruby/gems/1.9.1/gems/gstore-0.2.1/lib/
gstore/client.rb:40:in _http_request' from /usr/local/lib/ruby/gems/1.9.1/gems/gstore-0.2.1/lib/ gstore/client.rb:22:input’
from /usr/local/lib/ruby/gems/1.9.1/gems/gstore-0.2.1/lib/
gstore/object.rb:4:in put_object' from /var/www/rails/roboad/app/models/ad.rb:437:insave_file’
from (irb):4
from /usr/local/bin/irb:12:in `’>>

I’m stumped. Anyone have any timeout problems with ruby 1.9.3? The
problem is, if I want to use Rails 3.1, I have to use Ruby 1.9.3,
which now breaks all of my old Rails 2 apps.

I’d appreciate any help.

Thanks,
Kevin

On Nov 14, 11:47pm, KevinC [email protected] wrote:

I’m stumped. Anyone have any timeout problems with ruby 1.9.3? The
problem is, if I want to use Rails 3.1, I have to use Ruby 1.9.3,
which now breaks all of my old Rails 2 apps.

I’d appreciate any help.

I’ve no idea about the actual problem, but you should be able to use
1.8.7 with rails 3.1 - the release notes (http://
guides.rubyonrails.org/3_1_release_notes.html) explicitly say so. In
addition rails 3.1 came out something like 2 months before 1.9.3.

You might also want to consider using something like rbenv or rvm so
that you can juggle multiple versions of ruby for when you do have
projects compatible only with certain versions of ruby.

Fred

Thanks Fred. I just posted a separate thread on this, but will ask
here. I cannot install Rails 3.1 with Ruby 1.8.7 because it
complains:

Installing linecache19 (0.5.12)
Gem::InstallError: linecache19 requires Ruby version >= 1.9.2.

So, is it the case that Rails 3.1 actually requires Ruby 1.9.2?

Thanks again,
Kevin

On Nov 15, 5:02am, Frederick C. [email protected]

On Nov 16, 2:33pm, KevinC [email protected] wrote:

Thanks Fred. I just posted a separate thread on this, but will ask
here. I cannot install Rails 3.1 with Ruby 1.8.7 because it
complains:

Installing linecache19 (0.5.12)
Gem::InstallError: linecache19 requires Ruby version >= 1.9.2.

Do you have linecache19 or ruby-debug19 in your gem file? Those are
ruby 1.9 specific (linecache and ruby-debug are the 1.8.7
equivalents). I can certainly run an (admittedly trivial) rails 3.1.1
app on ruby 1.8.7

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs