Ruby 1.9.1 Rails 2.3.5 and Cucumber

Hey there,

Im running on Ubuntu 9.1.

I’ve installed rspec gems, cucumber gems.

When trying to run the features, I’m getting an error , it seems to be
the
TestUnit, which is not installed.

$rake cucumber features -n

rake aborted!
Could not find RubyGem test-unit (= 1.2.3)
/store/workspace/atom-commerce/Rakefile:10:in `require’

if I install test-unit, its a different version.

rake aborted!
RubyGem version error: test-unit(2.0.6 not = 1.2.3)
/store/workspace/atom-commerce/Rakefile:10:in `require’

What should I do? I’ve searched everywhere, can’t find answers.

Any might be able to help me.

Regards
Rodrigo D.

On Tue, Jan 19, 2010 at 4:34 PM, Rodrigo D.
[email protected]wrote:

rake aborted!
Could not find RubyGem test-unit (= 1.2.3)

Rodrigo, you need to install test-unit-1.2.3:

sudo gem install test-unit -v=1.2.3

Good luck,

-Conrad

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs