Ruby-1.9.1-p0 parallel build problem


#1

lyu0@lyu0-desktop:/tmp/ruby-1.9.1-p0$ rm uncommon.mk ; make -j5
rm: cannot remove `uncommon.mk’: No such file or directory
GNUmakefile:2: uncommon.mk: No such file or directory
make: warning: -jN forced in submake: disabling jobserver mode.
sed ‘s/{$([^(){}])[^{}]}//g’ common.mk > uncommon.mk
make: INTERNAL: Exiting with 1 jobserver tokens available; should be 5!
make: warning: -jN forced in submake: disabling jobserver mode.
gcc -O2 -g -Wall -Wno-parentheses -I. -I.ext/include/i686-linux
-I./include -I. -DRUBY_EXPORT -o time.o -c time.c
gcc -O2 -g -Wall -Wno-parentheses -I. -I.ext/include/i686-linux
-I./include -I. -DRUBY_EXPORT -o transcode.o -c transcode.c
gcc -O2 -g -Wall -Wno-parentheses -I. -I.ext/include/i686-linux
-I./include -I. -DRUBY_EXPORT -o util.o -c util.c
gcc -O2 -g -Wall -Wno-parentheses -I. -I.ext/include/i686-linux
-I./include -I. -DRUBY_EXPORT -o variable.o -c variable.c
gcc -O2 -g -Wall -Wno-parentheses -I. -I.ext/include/i686-linux
-I./include -I. -DRUBY_EXPORT -o version.o -c version.c
lyu0@lyu0-desktop:/tmp/ruby-1.9.1-p0$ echo $?
141
lyu0@lyu0-desktop:/tmp/ruby-1.9.1-p0$
So it breaks our buildsystem.

I think this problem is from GNUmakefile’s parallel build, two
"include"s.

Add .NOTPARALLEL: into GNUmakefile, I think everything will be ok.
It wont affect the submake in subdirectories.