Ruby-1.9.1 installation on RHEL-4


#1

Hi,

I am trying to install ruby-1.9.1 on my RHEL-4 system.

make install as su gives me this error:
.
.
.
.
Generating RI…
/home/vivek/churp/ruby-1.9.1-p0/lib/yaml.rb:9:in require': no such file to load -- stringio (LoadError) from /home/vivek/churp/ruby-1.9.1-p0/lib/yaml.rb:9:in<top
(required)>’ from
/home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/ri/descriptions.rb:1:in
require' from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/ri/descriptions.rb:1:in<top
(required)>’
from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/ri/reader.rb:2:in
require' from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/ri/reader.rb:2:in<top (required)>’
from
/home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/generator/ri.rb:5:in require' from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/generator/ri.rb:5:in<top
(required)>’
from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/rdoc.rb:268:in
require' from /home/vivek/churp/ruby-1.9.1-p0/lib/rdoc/rdoc.rb:268:indocument’
from ./bin/rdoc:15:in `’
make: *** [rdoc] Error 1

I have already tried installing ruby-1.8.7 and got some other error. I
hope this forum will help me.

Regards
Vivek


#2

I have already tried installing ruby-1.8.7 and got some other error. I
hope this forum will help me.

I might suggest reposting these to core if you get no responses here.
-=r


#3

On Feb 21, 8:42 am, Vivek S. removed_email_address@domain.invalid wrote:

Hi,

I am trying to install ruby-1.9.1 on my RHEL-4 system.

make install as su gives me this error:

This is for CentOS 4.5, but should work with RHEL. Just ignore the
Apache part and replace the 1.8.6 source with 1.9.1.

http://www.rubyhead.com/2007/12/05/installing-rails-server-centos-45/