Ruby 1.9.1 compatibility, again


#1

Hi all,

this patch against svn head allowed me to build Ruby-GNOME2 with Ruby
1.9.1. I have played around with it a bit in irb - simple windows and
buttons and stuff - and it seems to work.

Is that likely to be it, or are there more subtle failures lurking?

thanks,
Dan


Daniel Benjamin Lucraft

www.daniellucraft.com/blog
twitter.com/danlucraft


#2

Hi,

In removed_email_address@domain.invalid
“[ruby-gnome2-devel-en] Ruby 1.9.1 compatibility, again” on Mon, 27
Apr 2009 17:41:21 +0100,
Daniel L. removed_email_address@domain.invalid wrote:

this patch against svn head allowed me to build Ruby-GNOME2 with Ruby
1.9.1. I have played around with it a bit in irb - simple windows and
buttons and stuff - and it seems to work.

I can build without the patch. Could you show your build log
without the patch?

You may need to re-run extconf.rb to define correct HAVE_*
macros.

I used “ruby 1.9.1p0 (2009-01-30 revision 21907) [x86_64-linux]”
on Debian GNU/Linux sid.

Thanks,

kou


#3

2009/4/29 Kouhei S. removed_email_address@domain.invalid:

You may need to re-run extconf.rb to define correct HAVE_*
macros.

I used “ruby 1.9.1p0 (2009-01-30 revision 21907) [x86_64-linux]”
on Debian GNU/Linux sid.

OK I just tried with that revision of Ruby 1.9.1 and it built fine.
When I get back into work I’ll see what version I was using there,
check the extconf thing, and send in the output if it’s still bad.

thanks,
Dan


Daniel Benjamin Lucraft

www.daniellucraft.com/blog
twitter.com/danlucraft