Ruby 1.8.4 build failure on AIX 5.3

Hi,
I am trying to do a Ruby 1.8.4 build on AIX 5.3. The options passed
to configure are as follows
./configure --prefix=/usr/manas/ruby --disable-ipv6

I get the following error

    gcc -g -O2  -I. -I../.. -I../../. -I../.././ext/curses -

DHAVE_NCURSES_H -DHAVE_BEEP -DHAVE_BKGD -DHAVE_BKGDSET -DHAVE_CURS_SET
-DHAVE_DELETELN -DHAVE_DOUPDATE -DHAVE_FLASH -DHAVE_GETBKGD -
DHAVE_GETNSTR -DHAVE_ISENDWIN -DHAVE_KEYNAME -DHAVE_KEYPAD -
DHAVE_RESIZETERM -DHAVE_SCRL -DHAVE_SETSCRREG -DHAVE_UNGETCH -
DHAVE_WATTROFF -DHAVE_WATTRON -DHAVE_WATTR SET -DHAVE_WBKGD -
DHAVE_WBKGDSET -DHAVE_WDELETELN -DHAVE_WGETNSTR -DHAVE_WRESIZE -
DHAVE_WSCRL -DHAVE_WSETSCRREG -DHAVE_DEF_PROG_MODE -
DHAVE_RESET_PROG_MODE -DHAVE_TIMEOUT -DHAVE_WTIMEOUT -DHAVE_NODELAY -
DHAVE_INIT_COLOR -DHAVE_WCOLOR_SET -c curses.c
/usr/ccs/bin/ld -brtl -eInit_curses -bI:…/…/ruby.imp -bM:SRE
-T512 -H512 -L"…/…" -o …/…/.ext/powerpc-aix
5.3.0.0/curses.so curses.o -lncurses -ltermcap -ldl -lcrypt -lm -
lc
ld: 0706-006 Cannot find or open library file: -l ncurses
ld:open(): A file or directory in the path name does not
exist.

How do I install the ncurses library? I am not sure which package is
missing. My gcc info is as follows

gcc -v
Using built-in specs.
Target: powerpc-ibm-aix5.3.0.0
Configured with: …/configure --with-as=/usr/bin/as --with-ld=/usr/bin/
ld --disable-nls --enable-languages=c,c++ --prefi
x=/opt/freeware --enable-threads --enable-version-specific-runtime-
libs --host=powerpc-ibm-aix5.3.0.0
Thread model: aix
gcc version 4.0.0

Thanks in advance.

Regards,
-Manas

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs