Ruby 1.8.4 broke my Rails 1.1


#1

I’ve been running edge_rails on ruby 1.8.2 for a while pretty
successfully. Today, I decided to unfreeze_rails, install the new gem
for 1.1 and then while I was at it, upgrade to Ruby 1.8.4.

I did the whole configure, make, make test, make install.

When I fired up rails, I started getting all sorts of errors:
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/depende
ncies.rb:112:in const_missing': uninitialized constant DefaultLoader (NameError) from /usr/local/lib/ruby/site_ruby/1.8/yaml.rb:85 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:136:in
require' from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/base.rb:1 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:136:in
require' from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record.rb:37 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:175:in
activate' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:162:inactivate’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:161:in
activate' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:inrequire’
from /home/httpd/vhosts/xxxxxx/public/…/config/boot.rb:16
from /home/httpd/vhosts/xxxxxx/public/…/config/environment.rb:8
from /home/httpd/vhosts/xxxxxx/public/dispatch.fcgi:21

I even tried this on the command line:
% rails -h
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/depende
ncies.rb:112:in const_missing': uninitialized constant DefaultLoader (NameError) from /usr/local/lib/ruby/site_ruby/1.8/yaml.rb:85 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:136:in
`require’

I’m running Redhat 9:
Linux xxxxx.com 2.4.20-31.9 #1 Tue Apr 13 17:38:16 EDT 2004 i686
athlon i386 GNU/Linux

I reinstalled Ruby 1.8.2 and things are working again, but I’d really
like to get 1.8.4 working with Rails. Any hints?