Ruby 1.8 & 1.9 problem

hi
i had ruby 1.8.7 in my system. (Ubuntu 9.04)
so in console when i type:
which ruby
=> /usr/bin/ruby
ruby -v
=>ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

now i have installed ruby 1.9 side by side to the previous one and
something goes wrong during that. now in console:
which ruby
=>/usr/local/bin/ruby
ruby -v
=>ruby 1.9.0 (2007-12-25 revision 14709) [i686-linux]
ruby1.8 -v
=>ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]
ruby1.9 -v
=>ruby 1.9.0 (2008-06-20 revision 17482) [i486-linux]

problem is that now i’m not able to start web server i.e.
when i pass command ‘ruby script/server’ to start Webrick (inside my
rails application), the following error comes:

/home/abhi/Rails_Projects/Blog/vendor/rails/activesupport/lib/active_support/vendor.rb:33:in
require': no such file to load -- builder (LoadError) from /home/abh/Rails_Projects/Blog/vendor/rails/activesupport/lib/active_support/vendor.rb:33:inrescue in <top (required)>’
from
/home/abhi/Rails_Projects/Blog/vendor/rails/activesupport/lib/active_support/vendor.rb:2:in
<top (required)>' from /home/abhi/Rails_Projects/Blog/vendor/rails/activesupport/lib/active_support.rb:26:inrequire’
from
/home/abhi/Rails_Projects/Blog/vendor/rails/activesupport/lib/active_support.rb:26:in
<top (required)>' from /home/abhi/Rails_Projects/Blog/vendor/rails/railties/lib/commands/server.rb:1:inrequire’
from
/home/abhi/Rails_Projects/Blog/vendor/rails/railties/lib/commands/server.rb:1:in
<top (required)>' from script/server:3:inrequire’
from script/server:3:in `’

when i pass ‘ruby script/console’ :

/usr/local/lib/ruby/1.9.0/irb/completion.rb:10:in require': no such file to load -- readline (LoadError) from /usr/local/lib/ruby/1.9.0/irb/completion.rb:10:in<top
(required)>’
from /usr/local/lib/ruby/1.9.0/irb/init.rb:250:in require' from /usr/local/lib/ruby/1.9.0/irb/init.rb:250:inblock in
load_modules’
from /usr/local/lib/ruby/1.9.0/irb/init.rb:248:in each' from /usr/local/lib/ruby/1.9.0/irb/init.rb:248:inload_modules’
from /usr/local/lib/ruby/1.9.0/irb/init.rb:21:in setup' from /usr/local/lib/ruby/1.9.0/irb.rb:54:instart’
from /usr/local/bin/irb:13:in `’

can anyone guide me…?
thanx.

you will have to install gem and all your gems using the new ruby 1.9
installation. The gem install is isolated to the ruby install.

On Aug 30, 10:12 pm, Abhishek S. [email protected]

heimdull wrote:

you will have to install gem and all your gems using the new ruby 1.9
installation. The gem install is isolated to the ruby install.

On Aug 30, 10:12�pm, Abhishek S. [email protected]

which gems i should install.
when i type ‘gem list’
it shows:

LOCAL GEMS

how can i get the list of gems and how can i know that which gems are
required??
i am using rails 2.1.0

-Abhishek

[snip]

can anyone guide me…?

First, you’ll need to install Ruby 1.9.1 because it was the first
production
release of Ruby 1.9. Next, you should be able to install gems as
follows:

For Ruby 1.9.1:

sudo gem1.9 install

For Ruby 1.8.7:

sudo gem1.8 install

Good luck,

-Conrad

heimdull wrote:

you will have to install gem and all your gems using the new ruby 1.9
installation. The gem install is isolated to the ruby install.

On Aug 30, 10:12�pm, Abhishek S. [email protected]

how can i make my gems using ruby 1.9??

-abhishek

Hi…

If you want to work with both version use rvm…
http://www.rubyinside.com/rvm-ruby-version-manager-2347.html

Rejoice + o +
Arun K. .J
+91-97 89 89 19 33
http://railsbuilder.blogspot.com
Sent from Mahape, MH, India

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs