Rspec and autotest problems

Hello.

I am running rails 3. I installed the rspec, autotest gem. (OS Win7
64bit)

  1. When I run rspec the command is not recognized, I could find it in
    the ruby/bin folder as well.
  2. When I run autotest on a sample app (the one from chapter 3 from the
    railstutorial.org) I get something like this as an output:

The output should be something like two successful tests.
3. I installed autotest-growl and growl for windows… but when I run
autotest nothing happens in growl.

Please, help :slight_smile:

I had the exact same issues (also running Win7 64-bit). My fix for the
rspec issue was adding the path of my rspec.bat file to the environment
variable path. Mine looks something like this…

C:\server\Ruby192\lib\ruby\gems\1.9.1\bin

For autotest, I discovered I had two versions installed, 4.3.2 and
4.4.1. I went ahead and uninstalled them both and then ran…

gem install autotest

Everything seems to be working now.

current auto test has issues with latest rails and ruby i think , mine
also
stays in limbo after

loading autotest/rails

and im running on ubuntu in 2 machines and is the same result

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs